This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1010518 - [abrt] cura-13.04-2.fc19: special.py:323:glutInit:TypeError: 'NoneType' object is not callable
[abrt] cura-13.04-2.fc19: special.py:323:glutInit:TypeError: 'NoneType' objec...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: PyOpenGL (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christopher Meng
Fedora Extras Quality Assurance
abrt_hash:7d543fb6747749142b86d361d4c...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-20 23:15 EDT by chaceb94
Modified: 2014-10-27 12:48 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-10-27 12:48:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (1.26 KB, text/plain)
2013-09-20 23:16 EDT, chaceb94
no flags Details
File: dso_list (60 bytes, text/plain)
2013-09-20 23:16 EDT, chaceb94
no flags Details
File: environ (2.03 KB, text/plain)
2013-09-20 23:16 EDT, chaceb94
no flags Details

  None (edit)
Description chaceb94 2013-09-20 23:15:59 EDT
Description of problem:
I simply installed cura using 'sudo yum install cura' in my terminal on fedora 19 and then tried running cura by typing 'cura' into my terminal. I also tried 'sudo cura' to the same effect.

Version-Release number of selected component:
cura-13.04-2.fc19

Additional info:
reporter:       libreport-2.1.7
cmdline:        /usr/bin/python /bin/cura
executable:     /bin/cura
kernel:         3.11.1-200.fc19.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
special.py:323:glutInit:TypeError: 'NoneType' object is not callable

Traceback (most recent call last):
  File "/usr/lib64/python2.7/site-packages/wx-2.8-gtk2-unicode/wx/_core.py", line 14656, in <lambda>
    lambda event: event.callable(*event.args, **event.kw) )
  File "/usr/lib/python2.7/site-packages/Cura/gui/splashScreen.py", line 16, in DoCallback
    self.callback()
  File "/usr/lib/python2.7/site-packages/Cura/gui/app.py", line 39, in afterSplashCallback
    from Cura.gui import mainWindow
  File "/usr/lib/python2.7/site-packages/Cura/gui/mainWindow.py", line 9, in <module>
    from Cura.gui import preview3d
  File "/usr/lib/python2.7/site-packages/Cura/gui/preview3d.py", line 24, in <module>
    from Cura.gui.util import opengl
  File "/usr/lib/python2.7/site-packages/Cura/gui/util/opengl.py", line 20, in <module>
    glutInit()
  File "/usr/lib/python2.7/site-packages/OpenGL/GLUT/special.py", line 323, in glutInit
    _base_glutInit( ctypes.byref(count), holder )
TypeError: 'NoneType' object is not callable

Local variables in innermost frame:
count: c_int(1)
currentDirectory: '/usr/lib/python2.7/site-packages'
os: <module 'os' from '/usr/lib64/python2.7/os.pyc'>
args: ['foo']
i: 0
arg: 'foo'
holder: <OpenGL.GLUT.special.c_char_p_Array_1 object at 0x3168a70>
Comment 1 chaceb94 2013-09-20 23:16:02 EDT
Created attachment 800828 [details]
File: backtrace
Comment 2 chaceb94 2013-09-20 23:16:06 EDT
Created attachment 800829 [details]
File: dso_list
Comment 3 chaceb94 2013-09-20 23:16:14 EDT
Created attachment 800830 [details]
File: environ
Comment 4 Miro Hrončok 2013-09-21 09:08:19 EDT
Thanks for reporting. I have the very same version of the package and never got this error, will definitely look at it.

According to this [0] it appears to be missing freeglut, but that's not possible, as PyOpenGL requires it.

However this [1] leaded me to an idea: both Cura and PyOpenGL are noarch. PyOpenGL requires ANY freeglut. So after installing freeglut.i686 and removing freeglut.x86_64, lot's of stuff went away, but PyOpenGL and Cura stayed. After, I got the very same error.

So, could you please check, if you have 64bit freeglut? And if not, please check if installing cura without any freeglut brings 654bit or 32bit freeglut.

Here I got:

# yum remove freeglut cura PyOpenGL
...
# yum install cura # or PyOpenGL
...
 freeglut                                    x86_64  ...
...

That means you might have 32bit freeglut form some weird reason, but should not get it from yum.

[0] http://stackoverflow.com/questions/10188595/pyopengl-typeerror-nonetype-object-is-not-callable

[1] https://sourceforge.net/p/pyopengl/bugs/219/#034e

Note You need to log in before you can comment on or make changes to this bug.