Bug 101055 - tex crashes processing documents with long lines
tex crashes processing documents with long lines
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: xmlto (Show other bugs)
9
athlon Linux
medium Severity high
: ---
: ---
Assigned To: Tim Waugh
http://ksvanhorn.com/Personal/charent...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-28 16:27 EDT by Need Real Name
Modified: 2007-04-18 12:56 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-03-02 09:33:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-07-28 16:27:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.2.1) Gecko/20030225

Description of problem:
The indicated URL is a DocBook document listing all of the character entitities
in the DocBook DTD.  (It was intended as a reference document.)  It has a
section for each *.ent file in the DTD, and each section is a list with one
short descriptive element for each character entity.

When I run

  xmlto ps charent-nobreak.xml

the xmlto script crashes, with the following output:

----- begin output -----
Making portrait pages on USletter paper (8.5inx11in)
! Unable to read an entire line---bufsize=200000.
Please increase buf_size in texmf.cnf.
This is TeX, Version 3.14159 (Web2C 7.3.1)
(tmp.fo
LaTeX2e <2001/06/01>
Babel <v3.7h> and hyphenation patterns for american, french, german, ngerman, i
talian, nohyphenation, loaded.
xmltex version: 2000/09/07 v1.8y (Exp):
(/usr/share/texmf/tex/xmltex/xmltex.cfg)
No File: tmp.cfg
----- end output -----

I did a bit of investigating, and found that the intermediate output produced by
xsltproc consists of one very long line, with no line breaks at all.


Version-Release number of selected component (if applicable):
xmlto-0.0.12

How reproducible:
Always

Steps to Reproduce:
1. Get charent-nobreak.xml from the above URL
2. Run the command "xmlto ps charent-nobreak.xml".

    

Actual Results:  The xmlto script crashes, with the following output:

----- begin output -----
Making portrait pages on USletter paper (8.5inx11in)
! Unable to read an entire line---bufsize=200000.
Please increase buf_size in texmf.cnf.
This is TeX, Version 3.14159 (Web2C 7.3.1)
(tmp.fo
LaTeX2e <2001/06/01>
Babel <v3.7h> and hyphenation patterns for american, french, german, ngerman, i
talian, nohyphenation, loaded.
xmltex version: 2000/09/07 v1.8y (Exp):
(/usr/share/texmf/tex/xmltex/xmltex.cfg)
No File: tmp.cfg
----- end output -----


Expected Results:  Should have produced charent-nobreak.ps.


Additional info:
Comment 1 Tim Waugh 2003-07-29 05:35:15 EDT
This is a teTeX limitation, and modifying texmf.cnf doesn't actually seem to get
the limit beyond 300000.  Ideally we would be able to convince xsltproc to limit
the line length of its output.

In the mean time I've used sed in the xmlto format scripts to shorten the line
lengths. (Although in your particular example there seems to be another problem
after that.)
Comment 2 Tim Waugh 2003-07-29 05:45:02 EDT
Should be fixed upstream in xmlto-0.0.15pre2 (http://cyberelk.net/tim/xmlto).

Note You need to log in before you can comment on or make changes to this bug.