Bug 1010564 - I can't update to thunderbird-24.0-2.fc19.x86_64 because of missing suitable thunderbird-enigmail
I can't update to thunderbird-24.0-2.fc19.x86_64 because of missing suitable ...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: thunderbird-enigmail (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Remi Collet
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-21 09:36 EDT by Joachim Backes
Modified: 2013-10-08 09:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-21 09:41:55 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Backes 2013-09-21 09:36:43 EDT
Description of problem:
I tried to update to thunderbird-24.0-2.fc19 using yum, but this is rejected if thunderbird-enigmail is installed on my box:

sudo yum update --enablerepo=updates-testing

Resolving Dependencies
--> Running transaction check
---> Package thunderbird.x86_64 0:17.0.8-1.fc19 will be updated
--> Processing Dependency: thunderbird < 18.0 for package: thunderbird-lightning-1.9.1-2.fc19.x86_64
---> Package thunderbird.x86_64 0:24.0-2.fc19 will be an update
--> Processing Conflict: thunderbird-enigmail-1.5.2-1.fc19.x86_64 conflicts thunderbird >= 18.0
--> Finished Dependency Resolution
Error: thunderbird-enigmail conflicts with thunderbird-24.0-2.fc19.x86_64
Error: Package: thunderbird-lightning-1.9.1-2.fc19.x86_64 (@fedora)
           Requires: thunderbird < 18.0
           Removing: thunderbird-17.0.8-1.fc19.x86_64 (@updates-testing)
               thunderbird = 17.0.8-1.fc19
           Updated By: thunderbird-24.0-2.fc19.x86_64 (updates-testing)
               thunderbird = 24.0-2.fc19
           Available: thunderbird-17.0.6-2.fc19.x86_64 (fedora)
               thunderbird = 17.0.6-2.fc19
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Version-Release number of selected component (if applicable):
thunderbird-enigmail-1.5.2-1.fc19.x86_64 or follower

How reproducible:
always

Steps to Reproduce:
1.dee description
2.
3.

Actual results:
update rejected

Expected results:


Additional info:
Comment 2 Felix Schwarz 2013-10-08 09:12:51 EDT
The update was unpushed due to a Thunderbird security update (for Thunderbird 17) so technically I think the bug should be still open.

As Thunderbird 24 has landed in updates-testing for F19 maybe you can push a new update for enigmail?
Comment 3 Remi Collet 2013-10-08 09:45:29 EDT
Please, complain to Thunderbird owner, not to me.

Note You need to log in before you can comment on or make changes to this bug.