Bug 1010570 - drqcut in F20 is cluttering /var/log/messages
drqcut in F20 is cluttering /var/log/messages
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
20
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-21 12:05 EDT by Harald Reindl
Modified: 2014-04-02 06:23 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-02 04:34:53 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Harald Reindl 2013-09-21 12:05:41 EDT
this crap belongs to /var/log/dracut.log and not the general syslog
dracut-033-3.git20130913.fc20.x86_64

Sep 21 18:03:24 rawhide dracut[593]: <14>Executing: /usr/sbin/dracut -f
Sep 21 18:03:24 rawhide dracut[593]: <14>dracut module 'plymouth' will not be installed, because it's in the list to be omitted!
Sep 21 18:03:25 rawhide dracut[593]: <14>*** Including module: bash ***
Sep 21 18:03:25 rawhide dracut[593]: <14>*** Including module: i18n ***
Sep 21 18:03:25 rawhide dracut[593]: <14>*** Including module: kernel-modules ***
Sep 21 18:03:28 rawhide dracut[593]: <14>*** Including module: rootfs-block ***
Sep 21 18:03:28 rawhide dracut[593]: <14>*** Including module: terminfo ***
Sep 21 18:03:28 rawhide dracut[593]: <14>*** Including module: udev-rules ***
Sep 21 18:03:28 rawhide dracut[593]: <14>Skipping udev rule: 91-permissions.rules
Sep 21 18:03:28 rawhide dracut[593]: <14>*** Including module: systemd ***
Sep 21 18:03:28 rawhide dracut[593]: <14>*** Including module: base ***
Sep 21 18:03:28 rawhide dracut[593]: <14>*** Including module: fs-lib ***
Sep 21 18:03:28 rawhide dracut[593]: <14>*** Including module: shutdown ***
Sep 21 18:03:28 rawhide dracut[593]: <14>*** Including modules done ***
Sep 21 18:03:28 rawhide dracut[593]: <14>*** Installing kernel module dependencies and firmware ***
Sep 21 18:03:28 rawhide dracut[593]: <14>*** Installing kernel module dependencies and firmware done ***
Sep 21 18:03:28 rawhide dracut[593]: <14>*** Resolving executable dependencies ***
Sep 21 18:03:29 rawhide dracut[593]: <14>*** Resolving executable dependencies done***
Sep 21 18:03:29 rawhide dracut[593]: <14>*** Hardlinking files ***
Sep 21 18:03:29 rawhide dracut[593]: <14>*** Hardlinking files done ***
Sep 21 18:03:29 rawhide dracut[593]: <14>*** Stripping files ***
Sep 21 18:03:29 rawhide dracut[593]: <14>*** Stripping files done ***
Sep 21 18:03:29 rawhide dracut[593]: <14>*** Creating image file ***
Sep 21 18:03:31 rawhide dracut[593]: <14>*** Creating image file done ***
Comment 1 Harald Hoyer 2014-01-22 05:51:00 EST
This was a requested feature, so /var/log/dracut.log can be dropped and the systemd journal is the central place to look at.

Although there is a bug in the dracut logger, which leads to "<prio>" not be parsed by systemd-cat.
Comment 2 Harald Reindl 2014-01-22 06:01:08 EST
well, that leads in very large and cluttered logs
at the end you do not face the few interesting lines
i worked around with own rsyslog-rules

in general the amount of log-lines in systemd get extreme
there are *way too* much lines for a simple SSH login

https://bugzilla.redhat.com/show_bug.cgi?id=1053315
Comment 3 Harald Hoyer 2014-04-02 04:37:08 EDT
You can still set in a /etc/dracut.conf.d/logging.conf:

logfile=/var/log/dracut.log
sysloglvl=0
Comment 4 Harald Reindl 2014-04-02 06:23:03 EDT
that is a really bad transition and system defaults should refelct the usage of rsyslog instead force admins to change every bit of configuration only because rsyslog is no longer default

Note You need to log in before you can comment on or make changes to this bug.