Bug 101058 - MSA1000 disk array needs one line added to scsi_scan.h
Summary: MSA1000 disk array needs one line added to scsi_scan.h
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: kernel   
(Show other bugs)
Version: 2.1
Hardware: ia64 Linux
high
medium
Target Milestone: ---
Assignee: Tom Coughlan
QA Contact: Brian Brock
URL:
Whiteboard: HP says QU3/IPF show stopper
Keywords:
Depends On:
Blocks: 87937
TreeView+ depends on / blocked
 
Reported: 2003-07-28 20:42 UTC by Micah Parrish
Modified: 2007-11-30 22:06 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-26 16:28:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Micah Parrish 2003-07-28 20:42:36 UTC
Description of problem:
The MSA1000 disk array uses non-consecutive lun numbering and needs the
following line added to scsi_scan.h:
{"COMPAQ", "MSA1000", "*", BLIST_FORCELUN},

The line was added to the kernel.org sources sometime between 2.4.18 and 2.4.20.

Our customers need to be able to install their array without recompiling the
kernel, so could you please get that line into a AS2.1 errata kernel somehow?

Comment 1 Larry Troan 2003-07-30 16:30:25 UTC
ISSUE TRACKER  26348 opened as sev 1

Comment 2 Larry Troan 2003-07-30 16:34:00 UTC
IS THIS AS 2.1 OR TAROON (RHEL3) IPF. ISSUE TRACKER SAYS 3 BUT YOUR DESCRIPTION
IMPLIES 2.1........ (Bug needs to be NEEDINFO)

Comment 3 Micah Parrish 2003-07-30 16:50:08 UTC
This is fixed in the RHEL3 kernel due to being fixed in the kernel.org sources.
 What we need is the one line fix to be included in the next errata kernel for
2.1AS.

Comment 4 Larry Troan 2003-07-30 18:25:29 UTC
Confirmed that this is an AS2.1 QU2 bug with fix required in U3.

Comment 5 Larry Troan 2003-08-01 21:17:36 UTC
BLOCKER BUG.

Comment 6 Micah Parrish 2003-08-26 16:28:25 UTC
This has been fixed in the 2.4.18-3.37 errata kernel, so I am closing this bug now.


Note You need to log in before you can comment on or make changes to this bug.