Bug 1010583 - Computer won't resume from sleep
Computer won't resume from sleep
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-21 14:52 EDT by bugzilla.justin
Modified: 2013-10-01 22:31 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 22:31:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description bugzilla.justin 2013-09-21 14:52:28 EDT
Description of problem:
In Fedora 19 GNOME I click "Lock" to put the machine to sleep. The monitor turns off but my keyboard and mouse are still lit up (as expected). However it's impossible to get out of sleep - pressing keys on the keyboard, moving the mouse, pressing the power button - nothing wakes it up.

Pressing caps lock or num lock doesn't toggle the light on that specific key, so it's obvious key strokes aren't being registered.

The only way to use the computer again is to hit the reset button.


Version-Release number of selected component (if applicable):
Fedora 19, fully updated
Linux 3.11


How reproducible:
Always


Steps to Reproduce:
1. Click Lock in GNOME Shell
2. Press keys/move mouse


Actual results:
Nothing happens. Only way to make computer usable is to hardware reset.


Expected results:
Screen turns on. Can use computer.


Additional info:
The reason I'm filing this as a Kernel bug is because the system was working perfectly until Fedora 19 got the 3.11 kernel. That is when the issue started happening. When I boot back into an old 3.10 kernel (3.10.11-200.fc19.x86_64 to be exact) I'm unable to reproduce this issue.
Comment 1 bugzilla.justin 2013-09-21 14:58:08 EDT
System information:
http://paste.fedoraproject.org/41262/97898091/
Comment 2 bugzilla.justin 2013-10-01 22:31:29 EDT
3.11.2-201.fc19.x86_64 seems to have fixed the problem. All is good!

Note You need to log in before you can comment on or make changes to this bug.