Bug 1010681 - [RFE] Ad Hoc Domains - localization is set according to enum translator view and not via session context
[RFE] Ad Hoc Domains - localization is set according to enum translator view ...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: jasperreports-server-pro (Show other bugs)
3.4.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Shirly Radco
movciari
reports
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-22 10:01 EDT by Yaniv Lavi (Dary)
Modified: 2016-02-10 15:13 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-12 05:29:01 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Reports
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
sherold: Triaged+


Attachments (Terms of Use)
Case_37486_Workaround_Implementation_Instructions.pdf (161.80 KB, application/pdf)
2014-06-30 11:31 EDT, Shirly Radco
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 28221 master ABANDONED reports: added jar to support localization per session [WIP] Never

  None (edit)
Description Yaniv Lavi (Dary) 2013-09-22 10:01:00 EDT
Description of problem:
Localization is set according to enum translator view and not via session context.
This should be changed.

Version-Release number of selected component (if applicable):
3.3.0

How reproducible:
Always

Steps to Reproduce:
1. login using non english locale
2. create ad hoc report

Actual results:
All enum values are in english

Expected results:
Should be localized as well according to session

Additional info:
Comment 1 Yaniv Lavi (Dary) 2014-03-19 15:36:08 EDT
Moving to 3.5.0 due to capacity issues.



Yaniv
Comment 2 Shirly Radco 2014-06-02 08:17:08 EDT
Waiting for a respond from Jasper.
Due to limitations in using session parameter in domain query,
we can't localize the Ad hoc reports results.
Tried to use the Jar and process provided by Jasper but result is still insufficient.
Comment 3 Shirly Radco 2014-06-08 02:54:18 EDT
Open Case Number 00037486

Shirly
Comment 4 Yaniv Lavi (Dary) 2014-06-22 08:17:19 EDT
(In reply to Shirly Radco from comment #2)
> Waiting for a respond from Jasper.
> Due to limitations in using session parameter in domain query,
> we can't localize the Ad hoc reports results.
> Tried to use the Jar and process provided by Jasper but result is still
> insufficient.

We may still be able to do this using calculated columns. The column will display the localized string from filtered query, if it exists, and english from another query otherwise. Shirly, will that work?



Yaniv
Comment 5 Shirly Radco 2014-06-30 11:30:06 EDT
Jasper replied:

"The way to fail over would be to change the expression for the current locale calculated field to the following:

groovy('requestAttributes.request.locale.toString() == null ? "en_US" : requestAttributes.request.locale.toString()')

If you're trying to use this in a derived table, it won't work because derived tables don't yet support dynamic parameter values.

I sent the implementation instructions in an email last time.  I'm attaching them to the case as a PDF document for easier reference.

Steve"
Comment 6 Shirly Radco 2014-06-30 11:31:43 EDT
Created attachment 913464 [details]
Case_37486_Workaround_Implementation_Instructions.pdf
Comment 9 Shirly Radco 2014-08-18 10:34:37 EDT
Tried workaround from by Jasper.
Workaround is insufficient.

We will wait until Jasper adds this.

Shirly
Comment 11 Yaniv Lavi (Dary) 2014-09-08 10:52:34 EDT
Moving to JRS component since there is no working workaround and this is dependent on their fix.



Yaniv

Note You need to log in before you can comment on or make changes to this bug.