Bug 1010714 - Thunderbolt ethernet adapter - removing device causes instability
Thunderbolt ethernet adapter - removing device causes instability
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-22 13:53 EDT by Mads Kiilerich
Modified: 2013-09-23 14:40 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-23 14:40:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages (185.33 KB, text/plain)
2013-09-22 13:53 EDT, Mads Kiilerich
no flags Details

  None (edit)
Description Mads Kiilerich 2013-09-22 13:53:47 EDT
Created attachment 801272 [details]
/var/log/messages

MacBookPro10,1 with kernel-3.11.1-200.fc19.x86_64 and an external thunderbolt ethernet adaptor as http://arstechnica.com/apple/2012/06/hands-on-apples-thunderbolt-gigabit-ethernet-adapter/

The adapter shows up as

0a:00.0 Ethernet controller: Broadcom Corporation NetXtreme BCM57762 Gigabit Ethernet PCIe
	Subsystem: Apple Inc. Device 00f6
	Physical Slot: 9
	Flags: bus master, fast devsel, latency 0, IRQ 16
	Memory at ce100000 (64-bit, prefetchable) [size=64K]
	Memory at ce110000 (64-bit, prefetchable) [size=64K]
	Expansion ROM at ce120000 [disabled] [size=64K]
	Capabilities: [48] Power Management version 3
	Capabilities: [50] Vital Product Data
	Capabilities: [58] MSI: Enable- Count=1/8 Maskable- 64bit+
	Capabilities: [a0] MSI-X: Enable+ Count=6 Masked-
	Capabilities: [ac] Express Endpoint, MSI 00
	Capabilities: [100] Advanced Error Reporting
	Capabilities: [13c] Device Serial Number 00-00-40-6c-8f-58-ae-98
	Capabilities: [150] Power Budgeting <?>
	Capabilities: [160] Virtual Channel
	Capabilities: [1b0] Latency Tolerance Reporting
	Kernel driver in use: tg3

and works fine when plugged in before booting.

But removing the thing causes strange things to be logged and makes the system unstable.

Resume also doesn't work - presumably for the same reason.

Inserting the device after boot (or after removing) do not show up anywhere.
Comment 1 Josh Boyer 2013-09-23 10:35:53 EDT
As far as I know, the upstream kernel does not support thunderbolt.  Essentially it's just pci-e, but it is supposed to be magically controlled by the system firmware and the OS isn't supposed to have to do anything special.  However, on Apple machines this is apparently untrue because Apple decided to be different for some reason.

If you plug in a thunderbolt device after Linux is running on an Apple machine, you're just not going to see that device.  As for booting with it attached, that would work as you've seen, but I don't really know how device removal is handled at that point.  Clearly not well, but I'm not sure there is much we can do about it.

Note You need to log in before you can comment on or make changes to this bug.