Bug 1010728 - [abrt] backintime-kde-1.0.26-2.fc19: encfstools.py:165:check_fuse:KeyError: 'getgrnam(): name not found: fuse'
[abrt] backintime-kde-1.0.26-2.fc19: encfstools.py:165:check_fuse:KeyError: '...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: backintime (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Christopher Meng
Fedora Extras Quality Assurance
abrt_hash:a410104988f787b4ffc42d6d243...
:
: 1011272 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-22 16:43 EDT by James Wilson Harshaw IV
Modified: 2013-12-13 22:45 EST (History)
6 users (show)

See Also:
Fixed In Version: backintime-1.0.28-2.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-05 05:37:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (968 bytes, text/plain)
2013-09-22 16:43 EDT, James Wilson Harshaw IV
no flags Details
File: environ (1.73 KB, text/plain)
2013-09-22 16:43 EDT, James Wilson Harshaw IV
no flags Details
remove check for fuse group (1.03 KB, patch)
2013-09-23 04:00 EDT, Flavio Grossi
no flags Details | Diff
apply patch in spec (81 bytes, patch)
2013-09-23 04:01 EDT, Flavio Grossi
no flags Details | Diff
Final patch (1.65 KB, patch)
2013-09-26 00:15 EDT, Christopher Meng
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1225561 None None None Never

  None (edit)
Description James Wilson Harshaw IV 2013-09-22 16:43:33 EDT
Description of problem:
Just ran the program. Pressed ok then got an error.

Version-Release number of selected component:
backintime-kde-1.0.26-2.fc19

Additional info:
reporter:       libreport-2.1.7
cmdline:        python /usr/share/backintime/kde4/app.py
dso_list:       backintime-common-1.0.26-2.fc19.noarch
executable:     /usr/share/backintime/kde4/app.py
kernel:         3.11.1-200.fc19.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
encfstools.py:165:check_fuse:KeyError: 'getgrnam(): name not found: fuse'

Traceback (most recent call last):
  File "/usr/share/backintime/kde4/settingsdialog.py", line 1341, in accept
    if self.validate():
  File "/usr/share/backintime/kde4/settingsdialog.py", line 1191, in validate
    if not self.save_profile():
  File "/usr/share/backintime/kde4/settingsdialog.py", line 962, in save_profile
    mnt.pre_mount_check(mode = mode, first_run = True, **mount_kwargs)
  File "/usr/share/backintime/common/mount.py", line 120, in pre_mount_check
    return tools.pre_mount_check(first_run)
  File "/usr/share/backintime/common/encfstools.py", line 107, in pre_mount_check
    self.check_fuse()
  File "/usr/share/backintime/common/encfstools.py", line 165, in check_fuse
    fuse_grp_members = grp.getgrnam('fuse')[3]
KeyError: 'getgrnam(): name not found: fuse'

Local variables in innermost frame:
self: <encfstools.EncFS_mount object at 0x2058d90>
user: 'james'
Comment 1 James Wilson Harshaw IV 2013-09-22 16:43:36 EDT
Created attachment 801337 [details]
File: backtrace
Comment 2 James Wilson Harshaw IV 2013-09-22 16:43:39 EDT
Created attachment 801338 [details]
File: environ
Comment 3 Flavio Grossi 2013-09-23 03:59:19 EDT
i think in fedora 19 there's no fuse group anymore, so that check in backintime should be removed by deleting the following lines in backintime/common/sshtools.py:

fuse_grp_members = grp.getgrnam('fuse')[3]
if not user in fuse_grp_members:
    raise mount.MountException(...)


flavio
Comment 4 Flavio Grossi 2013-09-23 04:00:27 EDT
Created attachment 801534 [details]
remove check for fuse group
Comment 5 Flavio Grossi 2013-09-23 04:01:10 EDT
Created attachment 801535 [details]
apply patch in spec
Comment 6 Flavio Grossi 2013-09-23 04:02:07 EDT
i attached my proposed fix, please review

thank you,
flavio
Comment 7 James Wilson Harshaw IV 2013-09-23 12:27:25 EDT
Will review later today, thank you for your quick response.
Comment 8 Christopher Meng 2013-09-23 20:40:40 EDT
Just ping upstream with response.
Comment 9 James Wilson Harshaw IV 2013-09-23 20:42:17 EDT
(In reply to Christopher Meng from comment #8)
> Just ping upstream with response.

Ping upstream?
Comment 10 Christopher Meng 2013-09-23 20:43:43 EDT
(In reply to jwharshaw from comment #9)
> (In reply to Christopher Meng from comment #8)
> > Just ping upstream with response.
> 
> Ping upstream?

Yes, I just get response from upstream, he will look into bugs later.

Maybe we should wait for upstream or just fix it?
Comment 11 James Wilson Harshaw IV 2013-09-23 20:46:12 EDT
Oh you just told the package maintainer? How would we fix the problem our selves for everyone? or do you just mean fix and recompile it individually.
Comment 12 James Wilson Harshaw IV 2013-09-23 20:49:02 EDT
by the way we can get rid of of /home/user/Ubuntu One exclude, since it is Fedora.
Comment 13 Christopher Meng 2013-09-23 20:54:46 EDT
OK.
Comment 14 Christopher Meng 2013-09-26 00:11:49 EDT
*** Bug 1011272 has been marked as a duplicate of this bug. ***
Comment 15 Christopher Meng 2013-09-26 00:15:28 EDT
Created attachment 803229 [details]
Final patch

This should be the final patch I can provide.

Please test.
Comment 16 Flavio Grossi 2013-09-26 03:33:23 EDT
Christopher, i think the issue here is that the fuse group isn't used anymore in f19, so the exception that now is correctly catched creates an error that is misleading

i guess that check should be removed
Comment 17 lonelywoolf 2013-09-30 03:11:18 EDT
Do you steel need reports of testing your patch or i should wait for fix from maintainer?
Comment 18 J 2013-11-06 10:29:29 EST
Unsurprisingly the bug is also present for gnome as well:

Traceback (most recent call last):
  File "/usr/share/backintime/gnome/app.py", line 1017, in on_btn_settings_clicked
    settingsdialog.SettingsDialog( self.config, self.snapshots, self ).run()
  File "/usr/share/backintime/gnome/settingsdialog.py", line 1102, in run
    if not self.validate():
  File "/usr/share/backintime/gnome/settingsdialog.py", line 1246, in validate
    if not self.save_profile():
  File "/usr/share/backintime/gnome/settingsdialog.py", line 945, in save_profile
    mnt.pre_mount_check(mode = mode, first_run = True, **mount_kwargs)
  File "/usr/share/backintime/common/mount.py", line 120, in pre_mount_check
    return tools.pre_mount_check(first_run)
  File "/usr/share/backintime/common/sshtools.py", line 117, in pre_mount_check
    self.check_fuse()
  File "/usr/share/backintime/common/sshtools.py", line 196, in check_fuse
    fuse_grp_members = grp.getgrnam('fuse')[3]
KeyError: 'getgrnam(): name not found: fuse'

Is there any news of the fix being applied upstream?
Comment 19 Christopher Meng 2013-11-06 10:32:13 EST
(In reply to J from comment #18)
Fixed in 1.0.28 version, however this version introduce a new python module which is not in Fedora.

I will fix them soon.
Comment 20 Fedora Update System 2013-11-25 20:32:38 EST
backintime-1.0.28-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/backintime-1.0.28-2.fc19
Comment 21 Fedora Update System 2013-11-25 20:34:09 EST
backintime-1.0.28-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/backintime-1.0.28-2.fc20
Comment 22 Fedora Update System 2013-11-26 13:04:40 EST
Package backintime-1.0.28-2.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing backintime-1.0.28-2.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-22187/backintime-1.0.28-2.fc20
then log in and leave karma (feedback).
Comment 23 Fedora Update System 2013-12-05 05:37:50 EST
backintime-1.0.28-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 24 Fedora Update System 2013-12-13 22:45:18 EST
backintime-1.0.28-2.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.