Bug 1010785 - Installer ask twice for rtgov password when doing client only installation
Installer ask twice for rtgov password when doing client only installation
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Installer (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity medium
: CR2
: 6.0.0
Assigned To: Thomas Hauser
Len DiMaggio
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-23 01:07 EDT by Jiri Pechanec
Modified: 2014-02-06 10:29 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
When the user installs only the RTGov client, both the RTGov Server and Overlord credentials panels are asking for the RTGov server password. The password should only be asked for once. If rtgov client only selected, the overlord-commons-idp is not required and therefore Overlord credentials do not need to be obtained.
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
CR1 screenshot - new text has been successfully added (107.25 KB, image/png)
2014-01-23 12:15 EST, Len DiMaggio
no flags Details

  None (edit)
Description Jiri Pechanec 2013-09-23 01:07:10 EDT
When user installs client-only rtgov it is served with two forms
  - RTGov Server
  - Overlord credentials

Both are asking for a passowrd to rtgov server.

U suppose that Overlord Credentials screen should be present only when installing rtgov server.
Comment 1 Thomas Hauser 2013-09-23 08:15:04 EDT
I was under the impression that these two pieces of information were separate: As it stands now, the information gathered goes into two places:

RTGov Server panel information is placed into
 .../jboss-eap-6.1/standalone/configuration/overlord-rtgov.properties

"Overlord credentials" information is placed into 
.../jboss-eap-6.1/standalone/configuration/overlord-idp-users.properties .../jboss-eap-6.1/standalone/configuration/dtgov.properties

The "Overlord Credentials" panel is used during the DTGov ontology uploading process. I am not sure if the username / password for these two different panels are actually the same piece of information. It would be good to get some clarification on this.
Comment 2 Jiri Pechanec 2013-09-25 01:26:39 EDT
Please look at standalone/deployments/overlord-rtgov/gadget-web.war/WEB-INF/picketlink.xml. RTGov uses overlord-idp too. AFAIK there was a requirement to have RTGov and DTGov working as SSO.

So effectively one of the form configures client settings and the second configures server settings. What is strange that if you install both server and client it does not set overlord-rtgov.properties.

IMHO the set of inter-dependencies needs to be sorted it so I mark this as a beta blocker so an analysis is done.
Comment 3 Anne-Louise Tangring 2013-09-26 08:56:50 EDT
It there is a way to work around the confusion by documenting the reasoning, we should do that for Beta and look at what needs to be better from a UX perspective for GA.
Comment 4 Eric Wittmann 2013-09-26 09:27:59 EDT
It may actually be the case that for rtgov client-only we actually don't need to ask for both.

I just did an install of *only* rtgov-client using the FSW6 ER3 installer and the following were installed:

switchyard-bpel-console-server.war
switchyard-bpel-console.war
overlord-commons-idp.war
overlord-rtgov/overlord-rtgov.war

I suspect we don't need to be installing anything other than:

overlord-rtgov/overlord-rtgov.war

Further, because of this my guess is that we don't need to do any of the Overlord configuration work (including asking for the Overlord admin password).

All of that said, we could certainly add some text to the two credentials pages explaining what they are:

Overlord Admin Password:  allows users to log in to the S-RAMP, DTGov, and Gadget Server UIs as well as connect to the S-RAMP CLI.

RTGov Client Credentials+URL:  the information that the RTGov client will use when connecting to the RTGov server *on a different machine*.
Comment 5 Gary Brown 2013-09-26 09:40:33 EDT
I agree with Eric - if rtgov client only selected, the overlord-commons-idp is not required and therefore overlord credentials do not need to be obtained.

Not sure if switchyard-bpel-console* are relevant - are these also optional components, in which case the rtgov client only install shouldn't include those.
Comment 6 Thomas Hauser 2013-09-30 10:46:40 EDT
Text has been updated to be similar to Eric's examples. 

Additionally, if the user does not install S-RAMP, DTGov, or RTGov server (only FSW + RTGov Client-only install), the user will not be asked for the "Overlord Admin Password" any longer. If any of those options are chosen, the "Overlord Admin Password" is still displayed.
Comment 8 Jiri Pechanec 2013-10-07 01:32:20 EDT
Verified in ER4 04-Oct-2013 04:44
Comment 11 Jiri Pechanec 2013-12-20 03:01:41 EST
Back again in ER8
Comment 12 Thomas Hauser 2013-12-20 11:24:57 EST
Since the way that credentials are handled has changed since the beta, I'm not certain that this bug is applicable any longer; which part of the current configuration when installing only RTGov Client is incorrect? Since RTGov client cannot be installed without installing SwitchYard (which requires the FSW User), I'm not certain what changes I'd need to make nor what exactly is wrong in this scenario.
Comment 13 Jiri Pechanec 2014-01-07 03:51:59 EST
If rtgov client only is installed (no dtgova and sramp) then during the installation two config screens are present
 - Fuse Service Works Credentials
 - RT-Gov Server

What configures the form named "Fuse Service Works Credentials" when no overlord server side component is installed?
Comment 14 Thomas Hauser 2014-01-07 09:53:07 EST
Fuse Service Works Credentials will be used for the bpel-console in this situation.
Comment 15 Thomas Hauser 2014-01-10 11:08:53 EST
Explanatory text changed to the following:
"Since the RTGov Client Only option was selected, please supply the information that this client will use to connect to the RTGov Server."
Comment 16 Jiri Pechanec 2014-01-23 01:56:44 EST
Moving to CR2 for verification of explanatory text
Comment 17 Len DiMaggio 2014-01-23 12:14:25 EST
Verified in CR1 - see attached screenshot.
Comment 18 Len DiMaggio 2014-01-23 12:15:03 EST
Created attachment 854505 [details]
CR1 screenshot - new text has been successfully added

Note You need to log in before you can comment on or make changes to this bug.