Bug 1010865 - "--allow_change_district" option in man page is not supported by oo-admin-move
"--allow_change_district" option in man page is not supported by oo-admin-move
Status: CLOSED ERRATA
Product: OpenShift Container Platform
Classification: Red Hat
Component: Pod (Show other bugs)
1.2.0
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Luke Meyer
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-23 04:45 EDT by Ma xiaoqiang
Modified: 2017-03-08 12 EST (History)
5 users (show)

See Also:
Fixed In Version: openshift-origin-broker-util-1.9.13-1
Doc Type: Bug Fix
Doc Text:
Cause: Options on oo-admin-move were changed without updating man page. Consequence: Man page described --allow_change_district option which no longer exists, didn't describe --change_district. Fix: Updated the man page. Result: Man page is accurate and maybe even a little more helpful.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-13 10:06:11 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ma xiaoqiang 2013-09-23 04:45:02 EDT
Description of problem:
The man page of oo-admin-move has "--allow_change_district", but oo-admin-move with "--allow_change_district" option doesn't work; and "oo-admin-move -h" doesn't support this option.

Version-Release number of selected component (if applicable):
openshift-origin-broker-util-1.9.12-1.el6op.noarch

How reproducible:
always
Steps to Reproduce:
1.Check the man page of  oo-admin-move, it said that this command support "--allow_change_district" option
#man oo-admin-move 
2. Run "oo-admin-move --allow_change_district" and "oo-admin-move -h"
#oo-admin-move --allow_change_district

Actual results:
The man page of oo-admin-move has "--allow_change_district", but oo-admin-move with "--allow_change_district" option doesn't work.
Seen from the output of "oo-admin-move -h", "--allow_change_district" is already replace by "--change_district".
#oo-admin-move -h
== Synopsis
oo-admin-move: Move an app from one node to another
== Usage
oo-admin-move OPTIONS
Options:
--gear_uuid <gear_uuid>
    Gear uuid to move
--destination_district_uuid <district_uuid>
    Destination district uuid
-i|--target_server_identity <server_identity>
    Target server identity
-p|--node_profile <node_profile>
    Node profile
-t|--timeout
    timeout
--change_district
    Move to a different district other than the source district
-h|--help
    Show Usage info

Expected results:
the contents of man page should be same as the contents of help   

Additional info:
Comment 2 Luke Meyer 2013-10-07 15:54:42 EDT
The semantics of moves have changed. Changing districts is no problem in OSE 1.2, as long as the gear UID is available on the destination node/district.

So yes, "--allow_change_district" is gone. There's actually no need to tell oo-admin-move you're doing a cross-district move now; it figures that out.

In its place, you can give oo-admin-move directions as follows:

1. Move to node X - use -i|--target_server_identity server-identity
2. Move to district X - use --destination_district_uuid district-uuid
3. Move to any district but the present one - use --change_district
4. Move somewhere, anywhere, even the present node if it's not deactivated (which fails) - use no options.

Anyway; just need to change the man page to match the options.
Comment 3 Luke Meyer 2013-10-10 09:14:25 EDT
Fixed in origin-server:
commit 256874a0567bf1ed353836973c666dd62e3891ee
Author: Luke Meyer <lmeyer@redhat.com>
Date:   Tue Oct 8 15:50:32 2013 -0400
    <oo-admin-move> follow options change on man page

Cherry-picked to enterprise-server:
commit 83560057e2d34c361260502510bda4ecd8344331
Author: Luke Meyer <lmeyer@redhat.com>
Date:   Tue Oct 8 15:50:32 2013 -0400
Comment 4 Johnny Liu 2013-10-10 22:25:11 EDT
Currently the latest ose-1.2 puddle is shipping openshift-origin-broker-util-1.9.12-1, once new puddle shipping the package include this fix patch come out, QE will verify it.
Comment 5 Johnny Liu 2013-10-10 23:03:42 EDT
QE will download package from brewweb to verify this bug.
Comment 6 Ma xiaoqiang 2013-10-11 00:32:10 EDT
reproduce this problem on puddle-1-2-2013-10-08
1.man oo-admin-move
SYNOPSIS
       oo-admin-move [-h|--help] [--gear_uuid gear-uuid]
       [--destination_district_uuid district-uuid]
       [-i|--target_server_identity server-identity]
       [-p|--node_profile node-profile] [-t|--timeout time-out]
       [--allow_change_district true|false]

update package with openshift-origin-broker-util-1.9.13-1.el6op.noarch.rpm,then run "man oo-admin-move" again

#man oo-admin-move
SYNOPSIS
       oo-admin-move --gear_uuid gear-uuid
       [--change_district]
       [--destination_district_uuid district-uuid]
       [-i|--target_server_identity server-identity]
       [-p|--node_profile node-profile] [-t|--timeout time-out]

       oo-admin-move -h|--help
Comment 9 errata-xmlrpc 2014-01-13 10:06:11 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0019.html

Note You need to log in before you can comment on or make changes to this bug.