Bug 1010866 - bridge key doesn't exist anymore in vm.conf causing HA daemon to crash
bridge key doesn't exist anymore in vm.conf causing HA daemon to crash
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-hosted-engine-setup (Show other bugs)
3.3.0
Unspecified Unspecified
urgent Severity urgent
: ---
: 3.3.0
Assigned To: Sandro Bonazzola
movciari
integration
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-23 04:52 EDT by Sandro Bonazzola
Modified: 2015-09-22 09 EDT (History)
8 users (show)

See Also:
Fixed In Version: ovirt-hosted-engine-setup-1.0.0-0.5.beta1.el6ev
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:53:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19413 None None None Never
oVirt gerrit 19414 None None None Never
oVirt gerrit 19450 None None None Never

  None (edit)
Description Sandro Bonazzola 2013-09-23 04:52:58 EDT
Latest changes introduced for fixing bug #1008391 removed the bridge keyword from vm.conf.
That key was used by the HA daemon that is crashing without it.
Comment 1 Sandro Bonazzola 2013-09-23 05:01:56 EDT
patches 19413 and 19414 merged upstream master.
patch 19450 pushed to upstream ovirt-hosted-engine-setup-1.0 for 3.3.0.

Greg: I can't see the stabilization branch for ovirt-hosted-engine-ha, can you create it and cherry-pick 19414 with this bug in Bug-Url?
Comment 3 Sandro Bonazzola 2013-09-24 09:25:57 EDT
there will not be any stabilization branch in the near future for ha, so all patches are merged. Moving this bug to modified.
Comment 5 Charlie 2013-11-27 20:19:22 EST
This bug is currently attached to errata RHBA-2013:15257. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 6 Sandro Bonazzola 2013-12-05 05:44:28 EST
hosted engine is a new package, does not need errata for specific bugs during its development.
Comment 7 errata-xmlrpc 2014-01-21 11:53:27 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0083.html

Note You need to log in before you can comment on or make changes to this bug.