Bug 1010874 - Dist-geo-rep : geo-rep config log-level option takes invalid values and makes geo-rep status defunct
Dist-geo-rep : geo-rep config log-level option takes invalid values and make...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: geo-replication (Show other bugs)
mainline
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Ajeet Jha
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-23 04:57 EDT by Ajeet Jha
Modified: 2015-02-22 18:01 EST (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1000922
Environment:
Last Closed: 2014-04-17 07:48:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ajeet Jha 2013-09-23 04:57:09 EDT
+++ This bug was initially created as a clone of Bug #1000922 +++

Description of problem: The geo-rep config log-level option takes invalid values  and makes geo-rep status defunct. 

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
[root@redlemon ~]# gluster v geo  master root@10.70.43.25::slave config log-level Afafaef
geo-replication config updated successfully
[root@redlemon ~]# gluster v geo  master root@10.70.43.25::slave status
NODE                       MASTER    SLAVE                      HEALTH     UPTIME       
------------------------------------------------------------------------------------
redlemon.blr.redhat.com    master    root@10.70.43.25::slave    defunct    N/A          
redmoon.blr.redhat.com     master    root@10.70.43.25::slave    defunct    N/A          
redwood.blr.redhat.com     master    root@10.70.43.25::slave    defunct    N/A          
redcloud.blr.redhat.com    master    root@10.70.43.25::slave    defunct    N/A  
>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>

Problem with this is , it can't be recovered just by resetting it, you have to stop and start the session. 

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>
[root@redlemon ~]# gluster v geo  master root@10.70.43.25::slave config \!log-level 
geo-replication config updated successfully
[root@redlemon ~]# gluster v geo  master root@10.70.43.25::slave status
NODE                       MASTER    SLAVE                      HEALTH     UPTIME       
------------------------------------------------------------------------------------
redlemon.blr.redhat.com    master    root@10.70.43.25::slave    defunct    N/A          
redwood.blr.redhat.com     master    root@10.70.43.25::slave    defunct    N/A          
redmoon.blr.redhat.com     master    root@10.70.43.25::slave    defunct    N/A          
redcloud.blr.redhat.com    master    root@10.70.43.25::slave    defunct    N/A

>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>



Version-Release number of selected component (if applicable):glusterfs-3.4.0.22rhs-2.el6rhs.x86_64


How reproducible:happens everytime


Steps to Reproduce:
1.create and start a geo-rep relationship between master and slave. 
2.set config log-level to some random value
3.check the geo-rep status


Actual results: The geo-rep status becomes defunct 


Expected results:It should error out properly if it get wrong values.


Additional info:
Comment 1 Anand Avati 2013-09-23 04:58:17 EDT
REVIEW: http://review.gluster.org/5989 (glusterd: Blocking invalid geo-rep config options for log-level.) posted (#2) for review on master by ajeet jha (ajha@redhat.com)
Comment 2 Anand Avati 2013-09-26 06:51:26 EDT
REVIEW: http://review.gluster.org/5989 (glusterd: Validating invalid log-level under geo-rep config options.) posted (#3) for review on master by ajeet jha (ajha@redhat.com)
Comment 3 Anand Avati 2013-10-04 00:25:34 EDT
COMMIT: http://review.gluster.org/5989 committed in master by Anand Avati (avati@redhat.com) 
------
commit a65d64e89c96b52b9805b63afbbc3e7b67dbc3ad
Author: Ajeet Jha <ajha@redhat.com>
Date:   Mon Sep 23 13:42:21 2013 +0530

    glusterd: Validating invalid log-level under geo-rep config options.
    
    Change-Id: I8ff6b48ef41fd6e9ea68c42dfb9878f8a08ed627
    BUG: 1010874
    Signed-off-by: Ajeet Jha <ajha@redhat.com>
    Reviewed-on: http://review.gluster.org/5989
    Reviewed-by: Avra Sengupta <asengupt@redhat.com>
    Reviewed-by: Amar Tumballi <amarts@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Venky Shankar <vshankar@redhat.com>
Comment 4 Ajeet Jha 2013-10-17 01:55:18 EDT
http://review.gluster.org/#/c/5989/
Comment 5 Niels de Vos 2014-04-17 07:48:29 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.