Bug 1010910 - Git push failed with JBOSS types app
Git push failed with JBOSS types app
Status: CLOSED NOTABUG
Product: OpenShift Container Platform
Classification: Red Hat
Component: Containers (Show other bugs)
2.2.0
Unspecified Linux
high Severity high
: ---
: ---
Assigned To: Brenton Leanhardt
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-23 05:38 EDT by nsun
Modified: 2016-05-25 09:23 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-24 23:10:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nsun 2013-09-23 05:38:26 EDT
Description of problem: 
It will be failed when push jboss app (jbosseap/jbossews1.0,2.0)

Version-Release number of selected component (if applicable):
OSE  RHN 1.2.3

How reproducible:
aways

Steps to Reproduce:
1.Create  a jbosseap app 
2.Modify something and git push it

Actual results:
...
remote: [ERROR] Failed to execute goal org.apache.maven.plugins:maven-resources-plugin:2.4.3:resources (default-resources) on project jbossews1: Execution default-resources of goal org.apache.maven.plugins:maven-resources-plugin:2.4.3:resources failed: Plugin org.apache.maven.plugins:maven-resources-plugin:2.4.3 or one of its dependencies could not be resolved: Could not transfer artifact org.codehaus.plexus:plexus-interactivity-api:jar:1.0-alpha-4 from/to central (http://repo1.maven.org/maven2): Error transferring file: Connection timed out -> [Help 1]
remote: [ERROR] 
remote: [ERROR] To see the full stack trace of the errors, re-run Maven with the -e switch.
remote: [ERROR] Re-run Maven using the -X switch to enable full debug logging.
remote: [ERROR] 
remote: [ERROR] For more information about the errors and possible solutions, please read the following articles:
remote: [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/PluginResolutionException
remote: An error occurred executing 'gear postreceive'
remote: 
remote: For more details about the problem, try running the command again with the '--trace' option.

Expected results:
Successed

Additional info:
Comment 3 Brenton Leanhardt 2013-09-23 07:48:10 EDT
Looks like it can't reach the maven repository:

Could not transfer artifact org.codehaus.plexus:plexus-interactivity-api:jar:1.0-alpha-4 from/to central (http://repo1.maven.org/maven2): Error transferring f
file: Connection timed out -> [Help 1]

That could be any number of problems but I would first check the network connectivity to that service.  Perhaps by using telnet or manually wget'ing a file.
Comment 4 nsun 2013-09-24 23:10:19 EDT
Git push successed at today. May be it's a network problem.

Note You need to log in before you can comment on or make changes to this bug.