Bug 1010926 - [virt-viewer] Both displays of a dual display guest VM are opened on one display on client
[virt-viewer] Both displays of a dual display guest VM are opened on one disp...
Status: CLOSED DUPLICATE of bug 1088921
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: spice-gtk (Show other bugs)
6.4
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Christophe Fergeau
Desktop QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-23 06:02 EDT by Jiri Belka
Modified: 2015-02-17 12:56 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-25 07:53:00 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
spice-xpi.log, messages (relevant part) (17.86 KB, application/x-gzip)
2013-09-23 06:02 EDT, Jiri Belka
no flags Details

  None (edit)
Description Jiri Belka 2013-09-23 06:02:16 EDT
Created attachment 801560 [details]
spice-xpi.log, messages (relevant part)

Description of problem:
I have a Windows 7 64bit VM (guest) with 2 displays. After setting guest OS to work with 2 displays, when I open console of this VM from RHEVM Administration Portal (fullscreen enabled, guest tools 3.2.15 installed, RHEV agent and RHEV spice agent running) I see it opens two virt-viewer windows (each for each guest's display) but the virt-viewer windows are opened on my client on same display-monitor. I would expect to see one guest's display opened on my first client display and second guest's display on my second client display. Having both guest's displays layered is quite strange.

Version-Release number of selected component (if applicable):
RHEVM 3.3
Windows 7 64bit + Windows guest tools 3.2.15 (3.3.x WGT are broken)
firefox-17.0.9-1.el6_4.x86_64
virt-viewer-0.5.2-18.el6_4.2.x86_64
spice-xpi-2.7-22.el6.x86_64

How reproducible:


Steps to Reproduce:
1. install w7 64bit with 3.2.15 tools, setup OS to work with 2 displays
2. console options - enable fullscreen -> open console
3.

Actual results:
both guest's displays opened by virt-viewer are only opened on one client display and are layered

Expected results:
both displays should be opened fullscreen, each of guest's display should be opened on separate client's displays

Additional info:
spice qe guys in brno showed me no issue with rhel65 (virt-viewer). I'm using still rhel 6.4!

xrandr 
Screen 0: minimum 320 x 200, current 1920 x 1980, maximum 8192 x 8192
LVDS1 connected 1600x900+0+1080 (normal left inverted right x axis y axis) 309mm x 174mm
   1600x900       60.0*+   40.0  
   1440x900       59.9     59.9  
   1360x768       60.0  
   1280x800       59.8     59.9  
   1280x768       59.9     60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   848x480        60.0  
   640x480        59.9  
VGA1 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
DP1 disconnected (normal left inverted right x axis y axis)
HDMI2 disconnected (normal left inverted right x axis y axis)
HDMI3 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 510mm x 287mm
   1920x1080      60.0*+   50.0  
   1920x1080i     30.0  
   1680x1050      59.9  
   1680x945       60.0  
   1400x1050      74.9     59.9  
   1600x900       60.0  
   1280x1024      75.0     60.0  
   1440x900       75.0     59.9  
   1280x960       60.0  
   1366x768       60.0  
   1360x768       60.0  
   1280x800       74.9     59.9  
   1152x864       75.0  
   1280x768       74.9     60.0  
   1280x720       50.0     60.0  
   1024x768       75.1     70.1     60.0  
   1024x576       60.0  
   832x624        74.6  
   800x600        72.2     75.0     60.3     56.2  
   720x576        50.0  
   848x480        60.0  
   720x480        59.9  
   640x480        72.8     75.0     66.7     60.0  
   720x400        70.1  
DP2 disconnected (normal left inverted right x axis y axis)
DP3 disconnected (normal left inverted right x axis y axis)
Comment 2 Jiri Belka 2013-09-23 07:23:38 EDT
On my RHEL6.4 client: spice-gtk-0.14-7.el6_4.3.x86_64
Comment 3 RHEL Product and Program Management 2013-10-13 21:59:58 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 Marc-Andre Lureau 2013-11-18 08:59:36 EST
(In reply to Jiri Belka from comment #0)
> Additional info:
> spice qe guys in brno showed me no issue with rhel65 (virt-viewer). I'm
> using still rhel 6.4!

Are you expecting a backport of the related fixes to rhel 6.4? why is the flag rhel-6.5.0 then?
Comment 5 Jiri Belka 2013-11-18 09:24:49 EST
pm-rhel@redhat.com set the flag, not me. I cannot answer your question, the decision it not for me.
Comment 6 Marc-Andre Lureau 2013-11-18 10:30:27 EST
(In reply to Jiri Belka from comment #5)
> pm-rhel@redhat.com set the flag, not me. I cannot answer your question, the
> decision it not for me.

Do we want to fix for 6.4z, or current working solution in 6.5 is enough?
Comment 7 Marc-Andre Lureau 2014-02-18 13:38:59 EST
I think this bug should be closed if it's now working fine on 6.5... (based on comment #0)
Comment 8 Marc-Andre Lureau 2014-04-25 07:53:00 EDT
without further info, I think it is quite reasonable to close it as bug #1088921. Please try with the coming 6.5z update.

*** This bug has been marked as a duplicate of bug 1088921 ***

Note You need to log in before you can comment on or make changes to this bug.