Bug 1010940 - Jenkins-client will be added into the app when adding jenkins-client without jenkins server in the domain
Jenkins-client will be added into the app when adding jenkins-client without ...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Linux
medium Severity medium
: ---
: ---
Assigned To: Abhishek Gupta
libra bugs
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-23 06:36 EDT by Lei Zhang
Modified: 2015-05-14 20:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-17 09:30:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lei Zhang 2013-09-23 06:36:35 EDT
Description of problem:
Given one normal app created(e.g., myphp), add jenkins-client to the app without jenkins server in the domain, and then show the app information.

[rayzhang@ray Work]$ rhc app create myphp php-5.3 
Application Options
-------------------
  Namespace:  ray1
  Cartridges: php-5.3
  Gear Size:  default
  Scaling:    no
.......................
.......................

Your application 'myphp' is now available.

[rayzhang@ray Work]$ rhc cartridge add -a  myphp -c jenkins-client-1 
Adding jenkins-client-1 to application 'myphp' ... 
A Jenkins server does not exist in this domain!
You must create a Jenkins server before installing this cartridge.

[rayzhang@ray Work]$ rhc app show myphp
myphp @ http://myphp-ray1.dev.rhcloud.com/ (uuid: 52400b6fa35a81ee5b000095)
---------------------------------------------------------------------------
  Domain:  ray1
  Created: 5:35 PM
  Gears:   1 (defaults to small)
  Git URL: ssh://52400b6fa35a81ee5b000095@myphp-ray1.dev.rhcloud.com/~/git/myphp.git/
  SSH:     52400b6fa35a81ee5b000095@myphp-ray1.dev.rhcloud.com
  php-5.3 (PHP 5.3)
  -----------------
    Gears: Located with jenkins-client-1
  jenkins-client-1 (Jenkins Client)
  ---------------------------------
    Gears: Located with php-5.3


Version-Release number of selected component (if applicable):
devenv-3810

How reproducible:
always

Steps to Reproduce:
1. Create one app
#rhc app create myphp php-5.3 
2. Add jenkins-client to the app without jenkins server in the domain
#rhc cartridge add -a  myphp -c jenkins-client-1
3. Show the app information 
#rhc app show myphp

Actual results:
Jenkins-client can be added into the app without jenkins server in the domain

Expected results:
Jenkins-client should not be added into the app without jenkins server in the domain 

Additional info:
Comment 1 Jhon Honce 2013-09-23 12:08:42 EDT
Using devenv_3812

# rhc app create myphp php-5.3

# rhc cartridge add -a  myphp -c jenkins-client-1
Adding jenkins-client-1 to application 'myphp' ... 
A Jenkins server does not exist in this domain!
You must create a Jenkins server before installing this cartridge.

Please re-open with additional instructions if you can reproduce.
Comment 2 Lei Zhang 2013-09-23 21:24:40 EDT
devenv_3814, When adding jenkins-client, It will show warning message, but jenkins-client has been added into the app.

Need 3 Steps:
Step 1
#rhc app create myphp php-5.3

Step 2
#rhc cartridge add -a  myphp -c jenkins-client-1
Adding jenkins-client-1 to application 'myphp' ... 
A Jenkins server does not exist in this domain!
You must create a Jenkins server before installing this cartridge.

Step 3
#rhc app show myphp
myphp @ http://myphp-chunchen.dev.rhcloud.com/ (uuid: 5240e86be5c99110fc000001)
-------------------------------------------------------------------------------
  Domain:  chunchen
  Created: 9:18 AM
  Gears:   1 (defaults to small)
  Git URL: ssh://5240e86be5c99110fc000001@myphp-chunchen.dev.rhcloud.com/~/git/myphp.git/
  SSH:     5240e86be5c99110fc000001@myphp-chunchen.dev.rhcloud.com

  php-5.3 (PHP 5.3)
  -----------------
    Gears: Located with jenkins-client-1

  jenkins-client-1 (Jenkins Client)
  ---------------------------------
    Gears: Located with php-5.3

you see, jenkins-client-1 has been added into the app.
Comment 3 Abhishek Gupta 2013-09-24 17:37:25 EDT
Cannot reproduce it anymore. I believe it was fixed with --> https://github.com/openshift/origin-server/pull/3683
Comment 4 Lei Zhang 2013-09-25 02:10:17 EDT
Verified on devenv_3824

[rayzhang@ray Work]$ rhc apps
myphp @ http://myphp-chunchen.dev.rhcloud.com/ (uuid: 5242746ec48d1eec2a000032)
-------------------------------------------------------------------------------
  Domain:  chunchen
  Created: 1:28 PM
  Gears:   1 (defaults to small)
  Git URL: ssh://5242746ec48d1eec2a000032@myphp-chunchen.dev.rhcloud.com/~/git/myphp.git/
  SSH:     5242746ec48d1eec2a000032@myphp-chunchen.dev.rhcloud.com

  php-5.3 (PHP 5.3)
  -----------------
    Gears: 1 small

You have 1 applications
[rayzhang@ray Work]$ rhc cartridge add -a myphp -c jenkins-client-1
Adding jenkins-client-1 to application 'myphp' ... 
A Jenkins server does not exist in this domain!
You must create a Jenkins server before installing this cartridge.

[rayzhang@ray Work]$ rhc app show myphp
myphp @ http://myphp-chunchen.dev.rhcloud.com/ (uuid: 5242746ec48d1eec2a000032)
-------------------------------------------------------------------------------
  Domain:  chunchen
  Created: 1:28 PM
  Gears:   1 (defaults to small)
  Git URL: ssh://5242746ec48d1eec2a000032@myphp-chunchen.dev.rhcloud.com/~/git/myphp.git/
  SSH:     5242746ec48d1eec2a000032@myphp-chunchen.dev.rhcloud.com

  php-5.3 (PHP 5.3)
  -----------------
    Gears: 1 small

Note You need to log in before you can comment on or make changes to this bug.