Bug 1011102 - Installer fails to install over an existing installation of SOA6
Installer fails to install over an existing installation of SOA6
Status: CLOSED CURRENTRELEASE
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Installer (Show other bugs)
6.0.0 GA
Unspecified Unspecified
unspecified Severity urgent
: ER7
: ---
Assigned To: Thomas Hauser
Len DiMaggio
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-23 11:47 EDT by Len DiMaggio
Modified: 2014-02-06 10:26 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-06 10:26:32 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot (930.27 KB, image/png)
2013-09-23 11:47 EDT, Len DiMaggio
no flags Details

  None (edit)
Description Len DiMaggio 2013-09-23 11:47:04 EDT
Description of problem:

The issue involves how we change the installed system slot definition. The error reported to the user is:

The product.conf file at <dir path> doesn't contain the expected value for an EAP installation. Please supply either an empty directory or an EAP installation.

The change is intentional - but we should at least document this for the user.

Version-Release number of selected component (if applicable):
6.0.0.ER3

How reproducible:
100%

Steps to Reproduce:
1. Install ER3
2. Attempt to install over the same dir
3.

Actual results:


Expected results:


Additional info:
Comment 1 Len DiMaggio 2013-09-23 11:47:30 EDT
Created attachment 801745 [details]
Screenshot
Comment 2 Thomas Hauser 2013-11-13 12:32:55 EST
Documenting the supported / unsupported installations is required.
Comment 3 Thomas Hauser 2013-12-12 11:14:07 EST
The installer will now give an error message detailing the reason why an installation fails. 

Example:

FSW cannot be layered with FSW and EAP (installing on top of itself.)
Comment 4 Pavol Srna 2013-12-13 08:10:52 EST
Verified in ER7.

Note You need to log in before you can comment on or make changes to this bug.