Bug 1011133 - [abrt] pronterface-0.0-32.20130711gitb8f549b.fc18: _core.py:9771:Refresh:TypeError: in method 'Window_Refresh', expected argument 1 of type 'wxWindow *'
[abrt] pronterface-0.0-32.20130711gitb8f549b.fc18: _core.py:9771:Refresh:Type...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: printrun (Show other bugs)
18
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miro Hrončok
Fedora Extras Quality Assurance
abrt_hash:a6046bc4a1dbafd6073931c4c00...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-23 12:24 EDT by novikovfb
Modified: 2014-02-05 18:14 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-05 18:14:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (666 bytes, text/plain)
2013-09-23 12:24 EDT, novikovfb
no flags Details
File: environ (1.69 KB, text/plain)
2013-09-23 12:24 EDT, novikovfb
no flags Details
file for reproduce error in pronterface (22.84 KB, application/octet-stream)
2013-09-26 12:37 EDT, novikovfb
no flags Details

  None (edit)
Description novikovfb 2013-09-23 12:24:31 EDT
Version-Release number of selected component:
pronterface-0.0-32.20130711gitb8f549b.fc18

Additional info:
reporter:       libreport-2.1.6
cmdline:        /usr/bin/python /usr/bin/pronterface
dso_list:       wxPython-2.8.12.0-3.fc18.i686
executable:     /usr/bin/pronterface
kernel:         3.10.11-100.fc18.i686
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
_core.py:9771:Refresh:TypeError: in method 'Window_Refresh', expected argument 1 of type 'wxWindow *'

Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/wx-2.8-gtk2-unicode/wx/_core.py", line 14656, in <lambda>
    lambda event: event.callable(*event.args, **event.kw) )
  File "/usr/lib/python2.7/site-packages/wx-2.8-gtk2-unicode/wx/_core.py", line 9771, in Refresh
    return _core_.Window_Refresh(*args, **kwargs)
TypeError: in method 'Window_Refresh', expected argument 1 of type 'wxWindow *'

Local variables in innermost frame:
args: (wxPython wrapper for DELETED StlViewPanel object! (The C++ object no longer exists.),)
kwargs: {}
Comment 1 novikovfb 2013-09-23 12:24:35 EDT
Created attachment 801760 [details]
File: backtrace
Comment 2 novikovfb 2013-09-23 12:24:38 EDT
Created attachment 801761 [details]
File: environ
Comment 3 Miro Hrončok 2013-09-25 05:47:01 EDT
Steps to reproduce?
Comment 4 novikovfb 2013-09-25 12:07:10 EDT
1. run Pronterface,
2. connect to printer via /dev/ttyUSB0 or not connect,
3. press "Compose" button,
4. load any *.stl file,
5. press "Done" button
then i have this error.
Comment 5 Miro Hrončok 2013-09-25 14:07:31 EDT
I cannot reproduce, are you sure this happens with any STL file?
Comment 6 novikovfb 2013-09-26 12:37:59 EDT
Created attachment 803479 [details]
file for reproduce error in pronterface

For example. This file reproduce error in Pronterface. File is generated by OpenSCAD.
Comment 7 Miro Hrončok 2013-09-27 05:31:29 EDT
I am not able to reproduce this on Fedora 18 32bit or on anything else. I'm terribly sorry.

There will be a new release of Printrun soon, so let's wait a bit and try again, OK?
Comment 8 novikovfb 2013-09-27 12:18:36 EDT
OK. So, slicing is working, this error registration is little annoying. I think, error is somewhere in closing "Compose" application, may be because computer is slow.
Comment 9 Miro Hrončok 2013-11-26 11:04:03 EST
Is this fixed?
Comment 10 novikovfb 2013-11-26 11:28:55 EST
No. New version also reproduce this error.
Comment 11 Miro Hrončok 2013-11-26 12:05:19 EST
For confirmation, what's the output of the following command?

rpm -q printrun

Could you please try upstream master branch? https://github.com/kliment/Printrun
If it's fixed there, say it and we'll try to locate the commit together.

If it's also present in there, could you report it upstream? As I'm unable to reproduce it, I really cannot help you in any other way, sorry.
Comment 12 novikovfb 2013-11-26 12:17:05 EST
[fedia@localhost ~]$ rpm -q printrun
пакет printrun не установлен 
[fedia@localhost ~]$ rpm -q pronterface 
pronterface-2013.10.19-6.fc18.i686 

Well, i try install printrun, may be printrun and pronterface are different.
Comment 13 Miro Hrončok 2013-11-26 12:18:48 EST
You don't need that one, my fault.

What about the upstream version from master?
Comment 14 novikovfb 2013-11-26 12:29:53 EST
[fedia@localhost ~]$ rpm -q printrun
printrun-2013.10.19-6.fc18.i686
This error is absent now. May be some file was broken or obsolete and install of printrun fix it.
Comment 15 Miro Hrončok 2013-11-26 13:35:52 EST
Definitely should not happen.

Could you please run:

yum -y remove printrun* && yum -y install pronterface

And then test again?
Comment 16 novikovfb 2013-11-27 11:38:37 EST
I have run:
yum -y remove printrun* && yum -y remove pronterface* && yum -y install pronterface
Error return again.
Comment 17 Miro Hrončok 2013-11-27 17:53:29 EST
This is weird. Still cannot reproduce it, but now we are getting somewhere.
Comment 18 Miro Hrončok 2013-11-27 17:54:05 EST
(in the meantime, let printrun be installed)
Comment 19 Fedora End Of Life 2013-12-21 10:37:12 EST
This message is a reminder that Fedora 18 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 18. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '18'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 18's end of life.

Thank you for reporting this issue and we are sorry that we may not be 
able to fix it before Fedora 18 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior to Fedora 18's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 20 Fedora End Of Life 2014-02-05 18:14:20 EST
Fedora 18 changed to end-of-life (EOL) status on 2014-01-14. Fedora 18 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.