Bug 1011140 - keyboard preview dialog too narrow by default
keyboard preview dialog too narrow by default
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: anaconda (Show other bugs)
7.1
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Vratislav Podzimek
Release Test Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-23 12:34 EDT by Tomas Capek
Modified: 2014-06-17 21:38 EDT (History)
4 users (show)

See Also:
Fixed In Version: anaconda-19.31.74-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 08:21:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomas Capek 2013-09-23 12:34:52 EDT
Description of problem:


By default, the keyboard preview dialog in the Keyboard spoke is too narrow to allow comfortably read various special characters, especially on notebook screens.


Expected results:

The dialog window is resizable - stretching it from the current ~70% width to ~90% seems to fix the problem sufficiently.

I suggest to increase the default size of the dialog to improve user experience.
Comment 3 Tomas Capek 2013-10-30 14:50:22 EDT
I checked in 19.31.30.1

For what it's worth, the fix seem to have made the window taller but not necessarily wider on a laptop screen because its dimensions can reportedly be only set to absolute values of fullscreen...
Comment 4 Tomas Capek 2014-03-12 10:07:20 EDT
Due to a bug in gtk that doesn't allow to properly resize the gkbd dialog, the dimensions of the dialog are now even less optimal than before the fix - width should be changed but isn't and height should have remained unchanged but is now bigger.

We better revert this thing if we can't fix it atm.

Thanks
Comment 5 Vratislav Podzimek 2014-03-12 10:12:30 EDT
Patch removing the problematic line available.
Comment 6 Jan Stodola 2014-04-08 09:27:03 EDT
The keyboard preview height is fixed in anaconda-19.31.75-1.el7.

Moving to VERIFIED.
Comment 7 Ludek Smid 2014-06-13 08:21:49 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.