Bug 1011180 - Displaced save/cancel buttons while updating environment from system's details tab
Displaced save/cancel buttons while updating environment from system's detail...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
Nightly
Unspecified Unspecified
medium Severity low (vote)
: Unspecified
: --
Assigned To: Eric Helms
Sachin Ghai
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-23 13:45 EDT by Sachin Ghai
Modified: 2014-07-02 10:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-02 10:08:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
displaced save/cancel buttons (85.70 KB, image/png)
2013-09-23 13:45 EDT, Sachin Ghai
no flags Details
tooltip added when updating a env (64.79 KB, image/png)
2014-04-28 01:37 EDT, Sachin Ghai
no flags Details

  None (edit)
Description Sachin Ghai 2013-09-23 13:45:21 EDT
Created attachment 801828 [details]
displaced save/cancel buttons

Description of problem:
Displaced save/cancel buttons while updating environment from system's details tab

Version-Release number of selected component (if applicable):
katello-1.4.6-1.git.246.3deb1a2.el6.noarch


How reproducible:
always

Steps to Reproduce:
1. Add a environment  like 'Library --> dev'
2. register a system with library
3. go to systems-> All-> select system--> details--> check 'dev' env

Actual results:
Displaced save/cancel button while updating the env.

Expected results:
Buttons should be visible along with environment instead of content-view

Additional info:
Comment 1 RHEL Product and Program Management 2013-09-23 13:46:50 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 3 Eric Helms 2013-10-01 08:36:49 EDT
The behavior you are seeing is the intended behavior. Anytime a user switches environments, they must choose a new content view to associate a system with. Once the content view is chosen and saved, the users environment selection is saved as well. If the user hits cancel, the environment is reverted back. We could add some help text to aide the user in understanding this tightly coupled relationship.
Comment 4 Sachin Ghai 2013-10-01 13:22:29 EDT
thank you for explaining the behaviour.  However either a help text or a tool tip would be nice to have.
Comment 5 Eric Helms 2013-10-03 06:56:13 EDT
As of 7b7afa9910243ba4182cac2bc3bf7f448e24dd95, a warning message has been added whenever a user changes environment to help better explain the connection between environment change and forcing the user to choose a new content view.
Comment 8 Mike McCune 2013-10-17 17:05:43 EDT
Moving this to be tested during MDP3, not critical for MDP2 success story
Comment 9 Sachin Ghai 2014-04-28 01:35:58 EDT
verified with:

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.9.7-1.el6_5.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.9.7-1.el6_5.noarch
* candlepin-tomcat6-0.9.7-1.el6_5.noarch
* elasticsearch-0.90.10-4.el6sat.noarch
* foreman-1.5.0.20-1.el6sat.noarch
* foreman-compute-1.5.0.20-1.el6sat.noarch
* foreman-libvirt-1.5.0.20-1.el6sat.noarch
* foreman-ovirt-1.5.0.20-1.el6sat.noarch
* foreman-postgresql-1.5.0.20-1.el6sat.noarch
* foreman-proxy-1.5.6-1.el6sat.noarch
* foreman-selinux-1.5.0-0.develop.el6sat.noarch
* katello-1.5.0-19.el6sat.noarch
* katello-apache-1.0-1.noarch
* katello-ca-1.0-1.noarch
* katello-certs-tools-1.5.5-1.el6sat.noarch
* katello-installer-0.0.34-1.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* pulp-katello-plugins-0.2-1.el6sat.noarch
* pulp-nodes-common-2.3.1-0.4.beta.el6sat.noarch
* pulp-nodes-parent-2.3.1-0.4.beta.el6sat.noarch
* pulp-puppet-plugins-2.3.1-0.4.beta.el6sat.noarch
* pulp-rpm-plugins-2.3.1-0.4.beta.el6sat.noarch
* pulp-selinux-2.3.1-0.4.beta.el6sat.noarch
* pulp-server-2.3.1-0.4.beta.el6sat.noarch
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-2.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-3.el6sat.noarch
* ruby193-rubygem-runcible-1.0.8-1.el6sat.noarch
* rubygem-hammer_cli-0.1.0-7.el6sat.noarch
* rubygem-hammer_cli_foreman-0.1.0-6.el6sat.noarch
* rubygem-hammer_cli_foreman_tasks-0.0.2-2.el6sat.noarch
* rubygem-hammer_cli_katello-0.0.3-17.el6sat.noarch

As per the comment3, this is an intended behaviour. however a tooltip was added to UI to make it clear from user perspective.
Comment 10 Sachin Ghai 2014-04-28 01:37:52 EDT
Created attachment 890338 [details]
tooltip added when updating a env
Comment 11 Bryan Kearney 2014-07-02 10:08:36 EDT
This was delivered with 6.0.3, which is the Satellite 6 Beta.
Comment 12 Bryan Kearney 2014-07-02 10:09:57 EDT
This was delivered in 6.0.3, the Beta version of Satellite 6.0

Note You need to log in before you can comment on or make changes to this bug.