Bug 1011275 - Anchor links in DocBuilder URL don't work the first time a page is opened in Firefox
Anchor links in DocBuilder URL don't work the first time a page is opened in ...
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: Web-UI (Show other bugs)
1.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Casperson
:
Depends On:
Blocks: 1013825
  Show dependency treegraph
 
Reported: 2013-09-23 21:26 EDT by Matthew Casperson
Modified: 2014-08-04 18:27 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 22:43:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Casperson 2013-09-23 21:26:42 EDT
Open the link http://docbuilder.usersys.redhat.com/13968/#About_This_Guide in Firefox (tested on Firefox 17 and 24), and the first time the browser will not stay at the top of the page. The second time the link is entered, the browser will scroll down to the correct position.

Chrome works OK.
Comment 1 Matthew Casperson 2013-09-23 21:27:22 EDT
This seems to happen with all anchors in DocBuilder pages.
Comment 2 Matthew Casperson 2013-09-23 21:33:33 EDT
Building the book with Publican and jumping to anchors works OK.
Comment 3 Misty Stanley-Jones 2013-09-25 21:58:01 EDT
I feel silly because I've noticed this for quite some time but thought "It must just be me"
Comment 4 Matthew Casperson 2013-10-01 21:54:50 EDT
Including jquery (even without any other scripts) causes this.
Comment 5 Matthew Casperson 2013-10-01 22:43:18 EDT
I'm not exactly sure what is causing this, but moving the jQuery script to the end of the HTML page instead of in the head fixes the issue.

There is no real downside to having the page load before the scripts (and all the scripts run after the DOM is ready anyway).

Any newly built specs will have the change enabled, and all books will pick it up with the next full rebuild.

Note You need to log in before you can comment on or make changes to this bug.