Bug 1011322 - Sometimes meet "Failed to correctly execute all parallel operations. " error when stopping postgresql or restarting nodejs app
Sometimes meet "Failed to correctly execute all parallel operations. " error ...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
low Severity low
: ---
: ---
Assigned To: Jhon Honce
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-24 01:30 EDT by Zhe Wang
Modified: 2015-05-14 19:28 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-11 23:05:41 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
the relevant logs of the errors (14.58 KB, text/x-log)
2013-09-24 01:30 EDT, Zhe Wang
no flags Details

  None (edit)
Description Zhe Wang 2013-09-24 01:30:15 EDT
Created attachment 802048 [details]
the relevant logs of the errors

Description of problem:
When stopping postgresql, it will sometime report the error:

Unable to complete the requested operation due to: Failed to correctly execute all parallel operations. 

Specifically, there were 5 jobs running against 1 large instance simultaneously. Please refer to the attached development.log for more info of the error.

Version-Release number of selected component (if applicable):
devenv_3816

How reproducible:
sometimes (of low frequency, only 2/29 postgresql cases failed due to this error. Have not found other cases failed by this problem yet.)

Steps to Reproduce:
1. create an app with postgresql db added
2. try to stop the postgresql cartridge
3.

Actual results:
Stopping the postgresql cartridge would sometimes fail with the error:

rhc cartridge stop postgresql-9.2 -a oprtj0 -l nimbeutz@redhat.com -p 'redhat' --insecure --server ec2-54-242-42-194.compute-1.amazonaws.com
Stopping postgresql-9.2 ... Unable to complete the requested operation due to: Failed to correctly execute all parallel operations.
Reference ID: 045f4eca49ceb89c04e58c70c82bedd8

Expected results:
Stopping the postgresql cartridge should be successful.

Additional info:
Comment 1 Dan McPherson 2014-02-07 18:57:15 EST
Is this still a problem?
Comment 2 Zhe Wang 2014-02-18 04:32:09 EST
Have not met this issue in recent sprints.
Comment 3 Zhe Wang 2014-02-18 20:53:33 EST
Move the bug to VERIFIED refer to comment#2.

Note You need to log in before you can comment on or make changes to this bug.