Bug 1011325 - Custom form layout - don't put whitespace between html elements
Custom form layout - don't put whitespace between html elements
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Form Modeler (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity medium
: ER4
: 6.0.0
Assigned To: Neus Miras
Jan Hrcek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-24 01:41 EDT by Jan Hrcek
Modified: 2014-08-06 16:08 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:08:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Whitespace when generating custom form layout - video to show the problem (2.24 MB, video/webm)
2013-09-24 01:41 EDT, Jan Hrcek
no flags Details

  None (edit)
Description Jan Hrcek 2013-09-24 01:41:00 EDT
Created attachment 802050 [details]
Whitespace when generating custom form layout - video to show the problem

Description of problem:
When using custom form layout and its feature 'Generate template based on ...' the HTML template is generated, but it has so many whitespaces between elements, so that at first look it seems that nothing was generated.

See video attached for steps to reproduce and to see what I mean.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. In group/repo/project demo > jbpm-playground > Evaluation open form evaluation-taskform
2. in Form Modeler go to form properties, select custom form layout and click Edit.
3. In 'Generate template based on' choose Default (but the problem is there also for the other options) and click OK next to it.
4. Examine the window displaying layout's HTML elements.

Actual results:
It seems there is nothing new generated there, but on closer look you can notice, that scrollbar appeared. This is because the form template with fields and labels IS generated, but there is so much whitespace between each element, that a lot of scrolling is needed.

Expected results:
No empty lines should be present between elements in the generated markup (also when using the other options 'aligned fields' and 'not aligned'). In ideal case the only whitespace that should be present should be formatting whitespace (e.g. the generated markup would be generated as if using for example http://xmlprettyprint.com)


Additional info:
With all the whitespaces a lot of scrolling is needed which makes it very hard to orient yourself in the markup.
Comment 1 Roger Martínez 2013-10-01 06:26:54 EDT
In today's build, there are some issues too:
	- In cutsom layout edit panel, available form fields select option boxes are empty, and the form contains some fields... So, the custom layout generation button does nothing.
	- Custom layout editor panel does not dissapear althought changing between tabs (Add fields by origin, by type..). Cancel button does nothing too.
Comment 4 Neus Miras 2013-10-02 04:23:05 EDT
Marek,

I'm sorry, it was a involuntary mistake.

Regards,
Neus.
Comment 8 Jan Hrcek 2013-10-21 02:44:58 EDT
I checked with BPMS 6.0.0 ER4. Unlike in previous build (ER3), the CKE Editor is present. But I'm unable to verify this bug because of https://bugzilla.redhat.com/show_bug.cgi?id=1019754

Leaving this ON_QA till the bugzilla 1019754 is fixed.
Comment 9 Jan Hrcek 2013-12-02 03:15:36 EST
Ok. Since now CKE Editor widget is used, which formats the HTML markup automatically, I consider this issue solved. Verified with BPMS 6.0.0 ER5

Note You need to log in before you can comment on or make changes to this bug.