Bug 1011334 - Unable to build bridge-utils
Unable to build bridge-utils
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: bridge-utils (Show other bugs)
6.5
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Thomas Woerner
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-24 02:28 EDT by Branislav Náter
Modified: 2016-01-22 10:41 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-22 10:41:35 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Branislav Náter 2013-09-24 02:28:00 EDT
Description of problem:
I'm unable to build bridge-utils from src package on rhel-6.5

Version-Release number of selected component (if applicable):
bridge-utils-1.2-10.el6

Steps to Reproduce:
1. rpm -ivh /mnt/redhat/brewroot/packages/bridge-utils/1.2/10.el6/src/bridge-utils-1.2-10.el6.src.rpm
2. rpmbuild -bb SPECS/bridge-utils.spec

Actual results:
<snip>
mkdir -p /root/rpmbuild/BUILDROOT/bridge-utils-1.2-10.el6.x86_64/usr/share/man/man8
install -m 644 brctl.8 /root/rpmbuild/BUILDROOT/bridge-utils-1.2-10.el6.x86_64/usr/share/man/man8
make[1]: Leaving directory `/root/rpmbuild/BUILD/bridge-utils-1.2/doc'
+ /usr/lib/rpm/brp-compress
+ /usr/lib/rpm/brp-strip
+ /usr/lib/rpm/brp-strip-static-archive
+ /usr/lib/rpm/brp-strip-comment-note
Processing files: bridge-utils-1.2-10.el6.x86_64
error: File not found: /root/rpmbuild/BUILDROOT/bridge-utils-1.2-10.el6.x86_64/usr/sbin/brctl
Executing(%doc): /bin/sh -e /var/tmp/rpm-tmp.UR6mRB
+ umask 022
+ cd /root/rpmbuild/BUILD
+ cd bridge-utils-1.2
+ DOCDIR=/root/rpmbuild/BUILDROOT/bridge-utils-1.2-10.el6.x86_64/usr/share/doc/bridge-utils-1.2
+ export DOCDIR
+ rm -rf /root/rpmbuild/BUILDROOT/bridge-utils-1.2-10.el6.x86_64/usr/share/doc/bridge-utils-1.2
+ /bin/mkdir -p /root/rpmbuild/BUILDROOT/bridge-utils-1.2-10.el6.x86_64/usr/share/doc/bridge-utils-1.2
+ cp -pr AUTHORS COPYING doc/FAQ doc/HOWTO /root/rpmbuild/BUILDROOT/bridge-utils-1.2-10.el6.x86_64/usr/share/doc/bridge-utils-1.2
+ exit 0


RPM build errors:
    File not found: /root/rpmbuild/BUILDROOT/bridge-utils-1.2-10.el6.x86_64/usr/sbin/brctl

Expected results:
Package successfully build
Comment 1 RHEL Product and Program Management 2013-10-13 19:07:45 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 2 Thomas Woerner 2014-02-17 10:08:43 EST
The rebuild of bridge-utils is working without problems for me. Please verify with 

rpmbuild --rebuild /mnt/redhat/brewroot/packages/bridge-utils/1.2/10.el6/src/bridge-utils-1.2-10.el6.src.rpm

I thing you might have missing devpendencies.
Comment 5 Branislav Náter 2014-03-25 13:10:35 EDT
Machine has been provided, developer was able to reproduce issue.
Comment 6 Branislav Náter 2016-01-22 10:41:35 EST
I'm not sure what have changed but I'm not able to reproduce issue anymore.

Note You need to log in before you can comment on or make changes to this bug.