Bug 10114 - Problems with fdisk (and disk druid) a large disk drive
Problems with fdisk (and disk druid) a large disk drive
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: util-linux (Show other bugs)
5.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-10 14:10 EST by Kevin Arnold
Modified: 2014-03-16 22:12 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-19 16:14:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Arnold 2000-03-10 14:10:21 EST
I just installed a 27.7GB Maxtor hard drive.  My BIOS was set to LBA mode
(Geometry of hda=3310,255,63).  This is a dual boot system and I wanted to
create a configuration something like:

hda1: 15MB ext2 for /boot
hda2: 1536MB fat32 for c:
hda3: 1536MB ext2 for /
hda4: Extended partition with rest of free space
hda5: 6144MB fat32 for d:
hda6: 4096MB fat32 for e:
hda7: 6144MB ext2 for /usr
hda8: 4096MB ext2 for /home
(swap on a seperate disk)

If I created these partitions using Partition Magic 4.0, disk druid would
fail to recognize the partition table during the RedHat Install.  Trying
to load Linux fdisk from a boot diskette resulted in an "Unable to read"
error message.

If I created these partitions using Fdisk, I would get a "Unable to write"
error message when I tried to write & exit.  After that, I got "Unable to
read" error messages when I tried to load fdisk again.

I tried several different partition configurations and the problem seemed
to stem from some combination of the number of partitions I created and
possibly the starting point of the last partition I created.  For example,
the above configuration could not be read, but if I *was* able to create
the partition and then create several 100MB partitions inside the extended
partition without a problem.  I could also create several small
parititions at the end of the disk without running into a problem.


I did finally come up with a way to install my dual boot system, but I now
have a parition table that fdisk cannot read.  This does not bother me now
(because I'm past the installation) but I will have a problem in the
future if I attempt to upgrade the system.   My work around to install
RedHat was to install to a small 1.5GB / partition without creating the
D:, E:, /usr, and /home partitions.  Then, after I finished installing
Windoze and RedHat 6.1, I used Partition Magic to create the additional
partitions.  Then I copied the /usr and /home directories from my /
partition onto the new ext2 partitions and used linuxconf to add mount
points for /usr and /home to the new partitions.

Obviously the Linux kernel has no problem reading the paritions, I only
ran into a problem while using fdisk and disk druid.
Comment 1 Riley H Williams 2000-03-11 14:55:59 EST
Not sure if this is connected with your problem, but do you have all the
partitions starting and finishing on cylinder boundaries?

Given the numbers you qoute, I would expect to see the following partition
table created:

   /dev/hda1  *       1        2        16033+    83  Linux native
   /dev/hda2          3      198      1574370      b  Win95 FAT32
   /dev/hda3        199      394      1574370     83  Linux native
   /dev/hda4        395     3310     23422770      5  Extended
   /dev/hda5        395     1178      6297448+     b  Win95 FAT32
   /dev/hda6       1179     1701      4200966      b  Win95 FAT32
   /dev/hda7       1702     2486      6305481     83  Linux native
   /dev/hda8       2486     3010      6618748+    83  Linux native

Do those figures look right to you?
Comment 2 juergen 2000-04-10 17:55:59 EDT
I got exactly the same problem. I tried several ways to bring it to work, but
they all failed. The hard disk is a IBM DPTA 20.5GB. The Mainboard was a Asus
P5A. I get the same error messages, even if I append kernel options like
"linear" or "hda=..." for the geometry of the disk. A computer with the same
disk and a Asus P3BF showed the same behaviour. On a MSI Board with Athlon and
this hard disk, I got it without any options to work. (Yes, I tried to install 3
Linux-Windows machines) I searched for differences in addressing or other Bios
options, but I found none. Even more curious is the fact, that when I put a hard
disk, where it didn4t work in a the computer that runs, the error messages are
still there. I don4t believe that both hard disks are defect.

I did some experiments and Linux-fdisk fails whenever I try to partition more
then about 8GB. If I make the partitions with windows-fdisk, Linux-fdisk can4t
read the partition table if there are partitions above 8GB. This limit sounds
like a known problem, but even after reading the Large-Disk-Howto and some
experiments with kernel options, I found no way to fix the problem.
Comment 3 juergen 2000-04-11 11:33:59 EDT
sorry, I found the problem. The jumpers of the hard disk were incorrectly set.
Perhaps the above problem is the same. Look for the settings of the jumpers for
the number of heads and sectors. Now the installation was no problem.
Comment 4 Cristian Gafton 2000-05-22 11:57:59 EDT
assigned to jbj

Note You need to log in before you can comment on or make changes to this bug.