Bug 1011414 - Packstack fails on missing utils function import
Packstack fails on missing utils function import
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-packstack (Show other bugs)
4.0
Unspecified Unspecified
unspecified Severity high
: beta
: 4.0
Assigned To: Solly Ross
Ami Jeain
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-24 04:48 EDT by Rami Vaknin
Modified: 2013-12-19 19:24 EST (History)
9 users (show)

See Also:
Fixed In Version: openstack-packstack-2013.2.1-0.6.dev763.el6ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:24:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rami Vaknin 2013-09-24 04:48:43 EDT
Version:
Havana on RHEL6.4
puddle: 4.0/2013-09-23.2


Description:
Packstack fails to install OpenStack, it throw the following exception after few seconds:

2013-09-24 11:24:57::ERROR::run_setup::913::root:: Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line 908, in main
    _main(confFile)
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line 577, in _main
    runSequences()
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line 554, in runSequences
    controller.runAllSequences()
  File "/usr/lib/python2.6/site-packages/packstack/installer/setup_controller.py", line 90, in runAllSequences
    sequence.run(self.CONF)
  File "/usr/lib/python2.6/site-packages/packstack/installer/core/sequences.py", line 105, in run
    step.run(config=config)
  File "/usr/lib/python2.6/site-packages/packstack/installer/core/sequences.py", line 52, in run
    raise SequenceError(str(ex))
SequenceError: global name 'utils' is not defined
Comment 2 Solly Ross 2013-09-24 17:24:24 EDT
See BZ 1011413 as well.  Same file
Comment 5 Scott Lewis 2013-11-19 11:54:30 EST
Auto adding >= MODIFIED bugs to beta
Comment 10 errata-xmlrpc 2013-12-19 19:24:44 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.