Bug 1011416 - Packstack fails on glance db_sync due to ImportError
Packstack fails on glance db_sync due to ImportError
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-glance (Show other bugs)
4.0
Unspecified Unspecified
unspecified Severity high
: beta
: 4.0
Assigned To: Flavio Percoco
Tzach Shefi
: TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-24 04:49 EDT by Rami Vaknin
Modified: 2016-04-26 09:54 EDT (History)
10 users (show)

See Also:
Fixed In Version: openstack-glance-2013.2-1.el6ost.src.rpm
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-19 19:24:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rami Vaknin 2013-09-24 04:49:46 EDT
Version:
Havana on RHEL6.4
puddle: 4.0/2013-09-23.2


Description:
OpenStack installation fails with the following error:

pplying 10.35.160.29_glance.pp
Applying 10.35.160.29_cinder.pp
10.35.160.29_keystone.pp :                   [ DONE ]               
                                                                                            [ ERROR ]

ERROR : Error during puppet run : notice: /Stage[main]/Glance::Registry/Exec[glance-manage db_sync]/returns: ImportError: cannot import name deploy



From the log file
=================

ESC[0;36mnotice: /Stage[main]/Glance::Registry/Glance_registry_config[keystone_authtoken/admin_tenant_name]/value: value changed '%SERVICE_TENANT_NAME%' to 'services'ESC[0m
ESC[0;36mnotice: /Stage[main]/Glance::Registry/Exec[glance-manage db_sync]/returns: Traceback (most recent call last):ESC[0m
ESC[0;36mnotice: /Stage[main]/Glance::Registry/Exec[glance-manage db_sync]/returns:   File "/usr/bin/glance-manage", line 6, in <module>ESC[0m
ESC[0;36mnotice: /Stage[main]/Glance::Registry/Exec[glance-manage db_sync]/returns:     from glance.cmd.manage import mainESC[0m
ESC[0;36mnotice: /Stage[main]/Glance::Registry/Exec[glance-manage db_sync]/returns:   File "/usr/lib/python2.6/site-packages/glance/cmd/manage.py", line 42, in <module>ESC[0m
ESC[0;36mnotice: /Stage[main]/Glance::Registry/Exec[glance-manage db_sync]/returns:     from glance.common import configESC[0m
ESC[0;36mnotice: /Stage[main]/Glance::Registry/Exec[glance-manage db_sync]/returns:   File "/usr/lib/python2.6/site-packages/glance/common/config.py", line 29, in <module>ESC[0m
ESC[0;36mnotice: /Stage[main]/Glance::Registry/Exec[glance-manage db_sync]/returns:     from paste import deployESC[0m
ESC[0;36mnotice: /Stage[main]/Glance::Registry/Exec[glance-manage db_sync]/returns: ImportError: cannot import name deployESC[0m
ESC[1;35merr: /Stage[main]/Glance::Registry/Exec[glance-manage db_sync]: Failed to call refresh: glance-manage db_sync returned 1 instead of one of [0] at /var/tmp/packstack/f7d153ae4db14133bd6111c83a4b6d3b/modules/glance/manifests/registry.pp:177ESC[0m
ESC[0;36mnotice: /Stage[main]/Glance::Api/Service[glance-api]/ensure: ensure changed 'stopped' to 'running'ESC[0m
ESC[0;36mnotice: /Stage[main]/Glance::Registry/Service[glance-registry]/ensure: ensure changed 'stopped' to 'running'ESC[0m
ESC[0;36mnotice: Finished catalog run in 26.30 secondsESC[0m

2013-09-24 11:35:15::ERROR::run_setup::913::root:: Traceback (most recent call last):
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line 908, in main
    _main(confFile)
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line 577, in _main
    runSequences()
  File "/usr/lib/python2.6/site-packages/packstack/installer/run_setup.py", line 554, in runSequences
    controller.runAllSequences()
  File "/usr/lib/python2.6/site-packages/packstack/installer/setup_controller.py", line 90, in runAllSequences
    sequence.run(self.CONF)
  File "/usr/lib/python2.6/site-packages/packstack/installer/core/sequences.py", line 105, in run
    step.run(config=config)
  File "/usr/lib/python2.6/site-packages/packstack/installer/core/sequences.py", line 52, in run
    raise SequenceError(str(ex))
SequenceError: Error during puppet run : notice: /Stage[main]/Glance::Registry/Exec[glance-manage db_sync]/returns: ImportError: cannot import name deployESC[0m

2013-09-24 11:35:15::INFO::run_setup::598::root:: Removing /var/tmp/packstack/f7d153ae4db14133bd6111c83a4b6d3b on 10.35.160.29 (if it is a remote host)
Comment 2 Gowrishankar Rajaiyan 2013-09-27 11:18:03 EDT
Do we have a work-around for this ?
Comment 3 Martin Magr 2013-10-01 09:18:58 EDT
This is Glance bug and AFAIK it should be fixed in recent Glance packages.
Comment 8 Tzach Shefi 2013-12-02 08:35:38 EST
Bug fix, verified 

Successfully installed several setups (All in one / distributed components) without getting this error. 

Red Hat Enterprise Linux Server release 6.5 (Santiago)

[root@cougar01 iso(keystone_admin)]# rpm -qa | grep openstack
openstack-keystone-2013.2-1.el6ost.noarch
openstack-utils-2013.2-2.el6ost.noarch
openstack-ceilometer-common-2013.2-1.el6ost.noarch
openstack-nova-conductor-2013.2-5.el6ost.noarch
openstack-nova-cert-2013.2-5.el6ost.noarch
redhat-access-plugin-openstack-4.0.0-0.el6ost.noarch
openstack-ceilometer-central-2013.2-1.el6ost.noarch
openstack-ceilometer-api-2013.2-1.el6ost.noarch
openstack-selinux-0.1.3-1.el6ost.noarch
openstack-packstack-2013.2.1-0.11.dev847.el6ost.noarch
openstack-glance-2013.2-3.el6ost.noarch
openstack-nova-api-2013.2-5.el6ost.noarch
openstack-ceilometer-compute-2013.2-1.el6ost.noarch
openstack-nova-console-2013.2-5.el6ost.noarch
openstack-nova-compute-2013.2-5.el6ost.noarch
openstack-nova-scheduler-2013.2-5.el6ost.noarch
openstack-neutron-2013.2-10.el6ost.noarch
openstack-neutron-openvswitch-2013.2-10.el6ost.noarch
python-django-openstack-auth-1.1.2-1.el6ost.noarch
openstack-dashboard-2013.2-5.el6ost.noarch
openstack-nova-common-2013.2-5.el6ost.noarch
openstack-nova-novncproxy-2013.2-5.el6ost.noarch
openstack-dashboard-theme-2013.2-5.el6ost.noarch
openstack-ceilometer-collector-2013.2-1.el6ost.noarch
Comment 11 errata-xmlrpc 2013-12-19 19:24:47 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1859.html

Note You need to log in before you can comment on or make changes to this bug.