Bug 1011435 - NPE when updating a cluster compatibility version
NPE when updating a cluster compatibility version
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
Unspecified Unspecified
urgent Severity urgent
: ---
: 3.3.0
Assigned To: Tal Nisan
Tareq Alayan
infra
: Triaged
: 1011458 1011594 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-24 05:26 EDT by Tal Nisan
Modified: 2016-02-10 14:01 EST (History)
9 users (show)

See Also:
Fixed In Version: is17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19506 None None None Never
oVirt gerrit 19523 None None None Never

  None (edit)
Description Tal Nisan 2013-09-24 05:26:09 EDT
Description of problem:
When trying to update a cluster compatibility version engine throws an NPE

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. In webadmin edit a cluster with all hosts in maintenance status
2. Select a version other then the current one
3. Click OK

Actual results:
NPE is thrown in engine and "Internal engine error" message pops in the webadmin

Expected results:
Cluster version will be changed

Additional info:
Comment 1 Tal Nisan 2013-09-24 05:30:58 EDT
Note that the cluster must have at least one host for the NPE to occur
Comment 3 Itamar Heim 2013-09-24 06:53:46 EDT
*** Bug 1011458 has been marked as a duplicate of this bug. ***
Comment 4 Itamar Heim 2013-09-24 13:48:40 EDT
*** Bug 1011594 has been marked as a duplicate of this bug. ***
Comment 5 Martin Pavlik 2013-10-03 04:53:19 EDT
works in is17
Comment 6 Itamar Heim 2014-01-21 17:32:16 EST
Closing - RHEV 3.3 Released
Comment 7 Itamar Heim 2014-01-21 17:32:17 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.