Bug 1011458 - Edit Cluster Compatibility version 3.2 to 3.3 fails on Internal Engine Error
Edit Cluster Compatibility version 3.2 to 3.3 fails on Internal Engine Error
Status: CLOSED DUPLICATE of bug 1011435
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
x86_64 Linux
urgent Severity urgent
: ---
: ---
Assigned To: nobody nobody
infra
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-24 06:39 EDT by Lukas Svaty
Modified: 2016-02-10 14:30 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-24 06:53:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine log of edit action (11.36 KB, text/x-log)
2013-09-24 06:39 EDT, Lukas Svaty
no flags Details

  None (edit)
Description Lukas Svaty 2013-09-24 06:39:45 EDT
Created attachment 802156 [details]
engine log of edit action

Description of problem:
When trying to configure cluster compatibility version from 3.2 to 3.3 while Host is assigned to cluster (in 'Up' or 'Maintanance' state) action fails on Internal Engine Error

full message:
Error while executing action Edit Cluster properties: Internal Engine Error

Version-Release number of selected component (if applicable):
is15

How reproducible:
100%

Steps to Reproduce:
1. Add DC with 3.2 compatibility version
2. Add Cluster with 3.2 compatibility version
3. Add Host to cluster
4. Try editting cluster to 3.3 compatibility version

Additional info:
engine stops action on NullPointerException:
UpdateVdsGroupCommand throw exception: java.lang.NullPointerException

attaching engine.log of action
Comment 1 Itamar Heim 2013-09-24 06:53:46 EDT

*** This bug has been marked as a duplicate of bug 1011435 ***

Note You need to log in before you can comment on or make changes to this bug.