This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1011463 - default window size too wide and short
default window size too wide and short
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-software (Show other bugs)
20
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-24 06:55 EDT by Adam Williamson
Modified: 2013-11-04 20:46 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-30 11:37:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
min-width of the gnome-software main window (275.00 KB, image/png)
2013-10-02 13:16 EDT, Ryan Lerch
no flags Details

  None (edit)
Description Adam Williamson 2013-09-24 06:55:34 EDT
My display configuration is two 1920x1080 monitors rotated to a vertical orientation: so my viewport is effectively 2160x1920.

When I did 'yum install gnome-software' and ran it for the very first time (from the Overview), the window that popped up was sized rather oddly. A screenshot of it tells me it's 1353x775 in size: wider than one of my monitors (it's usually conventional to make your window not span multiple displays by default), but very short, even though I have acres of vertical space available. 775 isn't enough vertical pixels to show all the Categories, so I have to scroll to see them, completely unnecessarily.
Comment 1 Adam Williamson 2013-09-24 06:56:44 EDT
It looks like I can make the window taller, but no narrower. I think the big banner image for the 'featured' app - GIMP - is forcing the window width to be at least 1353.
Comment 2 Ryan Lerch 2013-10-02 12:43:33 EDT
Adam, 

on my first opening of gnome-software, the window was not sized in this manner.

is this still happening in newer versions of gnome-software?
Comment 3 Adam Williamson 2013-10-02 12:48:10 EDT
I cannot tell for a few weeks, I'm away from the system in question. It may well depend on your display configuration.
Comment 4 Ryan Lerch 2013-10-02 13:09:47 EDT
okay, on the most recent packaged version gnome-software-3.10.0-1.fc20, the min-width i can shrink the window to is approx 882px.
Comment 5 Ryan Lerch 2013-10-02 13:15:25 EDT
882px was for the details page.

on the front page, with the banner, i am able to shrink it to approx 856px (see screenshot)

by your explaination that you counldnt resize the width, then the window most definity would have spread over two displays.

However, those minimum width values seem to be a lot smaller now, so i think this one is a non-issue.
Comment 6 Ryan Lerch 2013-10-02 13:16:58 EDT
Created attachment 806639 [details]
min-width of the gnome-software main window
Comment 7 Adam Williamson 2013-10-02 13:28:04 EDT
well, I'm not sure I'd agree with 'non-issue'. People often run in VMs, and 1024x768 is still the industry standard VM desktop size. We still try quite hard to make anaconda fit in 800x600, never mind 1024x768; we only gave up holding the line on 640x480 a couple of releases back.
Comment 8 Adam Williamson 2013-10-02 13:28:46 EDT
Actually, 1366x768 is a perfectly standard resolution for many new systems still.
Comment 9 Ryan Lerch 2013-10-08 15:31:14 EDT
(In reply to Adam Williamson from comment #8)
> Actually, 1366x768 is a perfectly standard resolution for many new systems
> still.

last time i checked, 1366 is most defintely greater than 856, so i am not sure a screen with a resolution of 1366 x 768 wont have any issues with an application that has a min-width of 856 pixels.
Comment 10 Ryan Lerch 2013-10-14 10:13:37 EDT
Adam,

Have you had a chance to test on your double-portrait setup yet?
Comment 11 Adam Williamson 2013-10-14 12:16:45 EDT
Sorry, still not on the same continent. I'm back in Canada on Oct 19th, should be able to check it then.
Comment 12 Richard Hughes 2013-10-30 11:37:58 EDT
I don't think it's a bug to have a min width of 856. We've got to lay out the content somehow....
Comment 13 Adam Williamson 2013-11-04 20:46:46 EST
Ryan: your math is entirely correct, btw. :) it'd be nice to fit in 800x600, but not world-ending.

Note You need to log in before you can comment on or make changes to this bug.