Bug 1011486 - [RHEVM] cannot assign bridgeless rhevm and VLAN network to the same host NIC
[RHEVM] cannot assign bridgeless rhevm and VLAN network to the same host NIC
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.3.0
x86_64 Linux
high Severity urgent
: ---
: 3.3.0
Assigned To: Moti Asayag
Meni Yakove
network
: Regression, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-24 08:15 EDT by Martin Pavlik
Modified: 2016-02-10 14:47 EST (History)
7 users (show)

See Also:
Fixed In Version: is17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 17:12:08 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log_collector (5.83 MB, application/x-xz)
2013-09-24 08:15 EDT, Martin Pavlik
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19631 None None None Never

  None (edit)
Description Martin Pavlik 2013-09-24 08:15:56 EDT
Created attachment 802200 [details]
log_collector

Description of problem:
cannot assign bridgeless rhevm and VLAN network to the same host NIC

Version-Release number of selected component (if applicable):
Red Hat Enterprise Virtualization Manager Version: 3.3.0-0.23.master.el6ev 
VDSM version 4.12.0-156.git6e499d6.el6ev

How reproducible:
100%

Steps to Reproduce:
1. setup rhevm as non-vm network, with boot protocol dhcp.
2. create a new tagged vlan logical network for vm network. ex:- vlan123 with tag 123
3. Apply vlan123 to eth0 interface on the host, with boot protocol "none"
4. Save network configuration

Actual results:
interface gets configured on the host, but in GUI nothing changes, VLAN123 seems to be not attached to host, no error message appears

Expected results:


Additional info:
Comment 1 Martin Pavlik 2013-09-24 08:20:20 EDT
2013-09-24 13:41:05,778 INFO  [org.ovirt.engine.core.vdsbroker.vdsbroker.SetupNetworksVDSCommand] (ajp-/127.0.0.1:8702-6) START, SetupNetworksVDSCommand(HostName = dell-05, HostId = b4d81838-2e25-4705-8d4c-d30ce91d3585, force=false, checkConnectivity=true, conectivityTimeout=120,
        networks=[VLAN123 {id=484a28d1-bc5d-4cd2-85b6-ef6b75dd0a3c, description=null, comment=null, subnet=null, gateway=null, type=null, vlanId=123, stp=false, dataCenterId=5849b030-626e-47cb-ad90-3ce782d831b3, mtu=0, vmNetwork=true, cluster=NetworkCluster {id={clusterId=null, networkId=null}, status=OPERATIONAL, display=false, required=true, migration=false}, providedBy=null, label=null}],
        bonds=[],
        interfaces=[em2 {id=f9d9d326-c947-41c5-b3aa-4298ce0fbdd9, vdsId=b4d81838-2e25-4705-8d4c-d30ce91d3585, name=em2, macAddress=d0:67:e5:f0:7f:03, networkName=null, bondName=null, bootProtocol=DHCP, address=10.34.67.1, subnet=255.255.255.224, gateway=null, mtu=1500, bridged=false, speed=1000, type=0, networkImplementationDetails=null},
                em1 {id=e8db76d4-f7ed-488a-96e2-aae17248d6a0, vdsId=b4d81838-2e25-4705-8d4c-d30ce91d3585, name=em1, macAddress=d0:67:e5:f0:7f:02, networkName=rhevm, bondName=null, bootProtocol=DHCP, address=10.34.66.51, subnet=255.255.255.0, gateway=10.34.66.254, mtu=1500, bridged=false, speed=1000, type=2, networkImplementationDetails={inSync=true, managed=true}},
                p1p2 {id=87270347-0f00-4a7f-91c0-c94bb4d84153, vdsId=b4d81838-2e25-4705-8d4c-d30ce91d3585, name=p1p2, macAddress=90:e2:ba:04:2d:75, networkName=null, bondName=null, bootProtocol=DHCP, address=10.34.67.34, subnet=255.255.255.224, gateway=null, mtu=1500, bridged=false, speed=1000, type=0, networkImplementationDetails=null},
                p1p1 {id=03cc474a-d412-4e68-8920-c1fcebdb6f74, vdsId=b4d81838-2e25-4705-8d4c-d30ce91d3585, name=p1p1, macAddress=90:e2:ba:04:2d:74, networkName=null, bondName=null, bootProtocol=DHCP, address=10.34.67.35, subnet=255.255.255.224, gateway=null, mtu=1500, bridged=false, speed=1000, type=0, networkImplementationDetails=null},
                em1.123 {id=null, vdsId=b4d81838-2e25-4705-8d4c-d30ce91d3585, macAddress=null, networkName=VLAN123, vlanId=123, bonded=null, bondName=null, bondOptions=null, bootProtocol=NONE, address=null, subnet=null, gateway=null, mtu=0, bridged=true, speed=null, type=0, networkImplementationDetails=null}],
        removedNetworks=[],
        removedBonds=[]), log id: 667075a



Thread-921::DEBUG::2013-09-24 13:41:05,618::BindingXMLRPC::974::vds::(wrapper) client [10.34.63.69]::call setupNetworks with ({'VLAN123': {'nic': 'em1', 'vlan': '123', 'STP': 'no', 'bridged': 'true'}}, {}, {'connectivityCheck': 'true', 'connectivityTimeout': 120}) {}
Comment 3 Meni Yakove 2013-10-01 07:53:05 EDT
vdsm-4.12.0-170.el6ev.x86_64
Comment 4 Itamar Heim 2014-01-21 17:12:08 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.