Bug 1011488 - ltrace -f misses _exit call in vforked process
ltrace -f misses _exit call in vforked process
Status: CLOSED DUPLICATE of bug 802746
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ltrace (Show other bugs)
6.5
ppc64 Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Petr Machata
Michael Petlan
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-24 08:19 EDT by Michael Petlan
Modified: 2015-05-04 21:38 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-23 16:51:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Reproducer (703 bytes, application/x-tar)
2013-09-24 08:19 EDT, Michael Petlan
no flags Details

  None (edit)
Description Michael Petlan 2013-09-24 08:19:02 EDT
Created attachment 802202 [details]
Reproducer

Description of problem:

When ltracing a program with vfork, not all of the _exit calls are catched.

Version-Release number of selected component (if applicable):

ltrace-0.5-23.45svn.el6.ppc64

How reproducible: 100%

Steps to Reproduce:
1. run the attached reproducer
-- or --
1. ltrace -f -o ltrace.log ./vfork64
2. cat ltrace.log | grep _exit

Actual results:

There's only one _exit call in the ltrace, although there should be two of them.

Expected results:

There are all of the calls made by traced app.

Additional info:

- This issue happens only when tracing a 64bit application on ppc64. When you build the same app with -m32 option, everything passes well.

- It happens only on ppc64

- When vfork is substituted by fork, everything passes well.

- The call which is lost is the _exit() call of the parent process.
Comment 2 RHEL Product and Program Management 2013-10-13 19:07:27 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 3 Petr Machata 2014-09-23 16:51:58 EDT

*** This bug has been marked as a duplicate of bug 802746 ***

Note You need to log in before you can comment on or make changes to this bug.