Bug 1011505 - AcquireLockFailure failed to AttachStorageDomainVDS, Cannot obtain lock, wrong lease value
AcquireLockFailure failed to AttachStorageDomainVDS, Cannot obtain lock, wron...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity medium
: ---
: 3.3.0
Assigned To: Federico Simoncelli
Gadi Ickowicz
storage
: AutomationBlocker, Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-24 08:44 EDT by David Caro
Modified: 2016-06-26 19:50 EDT (History)
13 users (show)

See Also:
Fixed In Version: is17
Doc Type: Bug Fix
Doc Text:
Attaching a storage domain to the data center failed with an AcquireLockFailure error caused by an incorrect lease parameter value. The storage domain now uses the correct default lease value, so attaching the storage domain works as expected.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:16:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 19567 None None None Never

  None (edit)
Description David Caro 2013-09-24 08:44:13 EDT
Description of problem:
When attaching a storage domain (iscsi) to the datacenter vdsm fails and throws the error:
2013-09-24 11:50:17,855 ERROR [org.ovirt.engine.core.vdsbroker.irsbroker.AttachStorageDomainVDSCommand] (ajp-/127.0.0.1:8702-3) Error code AcquireLockFailure and error message IRSGenericException: IRSErrorException: Failed to AttachStorageDomainVDS, error = Cannot obtain lock: "id=df36e06f-9085-4f54-b0ba-edc02af6039a, rc=1, out=[], err=['panic: [31517] validate_lease_params: bad lease/op max timeouts: (Success)']"

It seems that the lease parameter has the wrong value.


Version-Release number of selected component (if applicable):
rhevm 3.3.0-0.99.master.el6ev
vdsm 4.12.0-156.git6e499d6

How reproducible:


Steps to Reproduce:
1.Create iscsi datacenter
2.Create cluster
3.Create storage domain
4.Attach storage domain to cluster

Actual results:
Attach failed

Expected results:
Attach succeeded

Additional info:
You can check the jenkins job here:
http://jenkins-ci.eng.lab.tlv.redhat.com/view/0%20Unstable%203.3/job/rhevm_3.3_automation_storage_export_import_desktop_factory/ENGINE=rest,HOST_HOSTGROUP=P-RHEVM-3.3-RHEL65-HOSTS,STORAGE_TYPE=iscsi,label=RHEVM-3.3-ENGINE-RHEL65/469/consoleFull
Comment 1 Federico Simoncelli 2013-09-25 05:05:24 EDT
Not moving to POST yet as I don't know yet if the patch provided addresses all the issues.
Comment 2 Federico Simoncelli 2013-09-25 07:44:56 EDT
Moving to POST since at least one scenario is covered.
Comment 3 Ayal Baron 2013-09-29 04:49:30 EDT
Patch does not address the problem
Comment 5 Ayal Baron 2013-09-29 05:29:25 EDT
(In reply to Ayal Baron from comment #3)
> Patch does not address the problem

Please ignore, this is not correct.
Comment 6 Gadi Ickowicz 2013-10-06 03:19:42 EDT
Verified on is17.1 - attaching second domain and export domain works as expected
Comment 7 Charlie 2013-11-27 19:32:17 EST
This bug is currently attached to errata RHBA-2013:15291. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 8 errata-xmlrpc 2014-01-21 11:16:23 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0040.html

Note You need to log in before you can comment on or make changes to this bug.