Bug 1011510 - font cache is broken by the race condition
font cache is broken by the race condition
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: fontconfig (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Akira TAGOH
Desktop QE
: i18n
: 1014988 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-24 08:51 EDT by Mike FABIAN
Modified: 2014-06-18 00:35 EDT (History)
7 users (show)

See Also:
Fixed In Version: fontconfig-2.10.95-5.el7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-13 09:20:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tamil-shown-as-boxes.png (93.44 KB, image/png)
2013-09-24 08:51 EDT, Mike FABIAN
no flags Details
fedora-20-alpha-rc4-tamil-fonts.png (11.17 KB, image/png)
2013-09-24 18:00 EDT, Mike FABIAN
no flags Details
tamil-shown-correctly-in-RHEL-7.0-20130925.n.0.png (161.64 KB, image/png)
2013-09-25 12:41 EDT, Mike FABIAN
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 69845 None None None Never

  None (edit)
Description Mike FABIAN 2013-09-24 08:51:30 EDT
Created attachment 802212 [details]
tamil-shown-as-boxes.png

Booting qemu using

http://download.devel.redhat.com/composes/nightly/RHEL-7.0-20130923.n.0/compose/Workstation/x86_64/os/images/boot.iso

like this

ionice -c 3 qemu-kvm -enable-kvm -m 2048M -smp 4 -drive file=./RHEL-7.0-20130923.n.0-Workstation-x86_64-boot.iso.qcow2,index=0,media=disk,cache=unsafe -localtime -serial file:/tmp/qemu-RHEL-7.0-20130923.n.0-Workstation-x86_64-boot.iso.qcow2-output.log -name RHEL-7.0-20130923.n.0-Workstation-x86_64-boot.iso.qcow2 -cdrom /local/mfabian/iso/RHEL-7.0-20130923.n.0/boot.iso -boot c -spice port=6001,disable-ticketing -vga qxl -display vnc=:2 -net nic -net user,hostname=RHEL-7.0-20130923.n.0-Workstation-x86_64-boot.iso.qcow2,hostfwd=tcp::5561-:22 -monitor stdio -usb

shows boxes for Tamil in the first screen where the language
is selected.

See screenshot.

Probably there is no Tamil font in the image.
Comment 2 Vratislav Podzimek 2013-09-24 16:58:57 EDT
Mike, could you please try to find out which font we should add and in which package it lives? Thanks!
Comment 3 Mike FABIAN 2013-09-24 18:00:33 EDT
Created attachment 802519 [details]
fedora-20-alpha-rc4-tamil-fonts.png

Screenshot showing which Tamil fonts are available at the beginning
of a Fedora 20 Alpha RC4 installation.
Comment 4 Mike FABIAN 2013-09-24 18:02:57 EDT
So F20 Alpha RC4 has Lohit-Tamil.ttf *and* Lohit-Tamil-Classical.ttf.

One of them should be enough if you want to save space.

According to fontconfig, both of them support Tamil:

mfabian@ari:~
$ fc-list "Lohit Tamil" lang 
:lang=ta
mfabian@ari:~
$ fc-list "Lohit Tamil Classical" lang 
:lang=ta
mfabian@ari:~

Package names:

mfabian@ari:~
$ rpm -qf /usr/share/fonts/lohit-tamil/Lohit-Tamil.ttf
lohit-tamil-fonts-2.5.3-1.fc19.noarch
mfabian@ari:~
$ rpm -qf /usr/share/fonts/lohit-tamil-classical/Lohit-Tamil-Classical.ttf 
lohit-tamil-classical-fonts-2.5.3-1.fc19.noarch
mfabian@ari:~
$ ftdump /usr/share/fonts/lohit-tamil/Lohit-Tamil.ttf
There is 1 face in this file.

----- Face number: 0 -----

font name entries
   family:     Lohit Tamil
   style:      Regular
   postscript: Lohit-Tamil

font type entries
   FreeType driver: truetype
   sfnt wrapped:    yes
   type:            scalable
   direction:       horizontal
   fixed width:     no
   glyph names:     yes
   EM size:         1024
   global BBox:     (-304,-363):(1766,861)
   ascent:          866
   descent:         -380
   text height:     1246
   glyph count:     247

charmaps
   0: platform 0, encoding  3   language 0
   1: platform 1, encoding  0   language 0
   2: platform 3, encoding  1   language 0 (active)
mfabian@ari:~
$ ftdump /usr/share/fonts/lohit-tamil-classical/Lohit-Tamil-Classical.ttf 
There is 1 face in this file.

----- Face number: 0 -----

font name entries
   family:     Lohit Tamil Classical
   style:      Regular
   postscript: Lohit-Tamil-Classical

font type entries
   FreeType driver: truetype
   sfnt wrapped:    yes
   type:            scalable
   direction:       horizontal
   fixed width:     no
   glyph names:     yes
   EM size:         1024
   global BBox:     (-304,-363):(1766,861)
   ascent:          866
   descent:         -380
   text height:     1246
   glyph count:     255

charmaps
   0: platform 0, encoding  3   language 0
   1: platform 1, encoding  0   language 0
   2: platform 3, encoding  1   language 0 (active)
mfabian@ari:~
$
Comment 5 Vratislav Podzimek 2013-09-25 09:30:30 EDT
Okay, so it seems that the fonts are there. Since AFAICT Pango is responsible rendering texts in Gtk, I'm reassinging this bug.
Comment 6 Mike FABIAN 2013-09-25 12:39:14 EDT
It is very strange, but it works in RHEL-7.0-20130925.n.0 !

How is that possible?
Comment 7 Mike FABIAN 2013-09-25 12:41:51 EDT
Created attachment 802949 [details]
tamil-shown-correctly-in-RHEL-7.0-20130925.n.0.png

Looks good in RHEL-7.0-20130925.n.0
Comment 8 Akira TAGOH 2013-09-26 00:18:46 EDT
I'm not quite sure why/how it happened but the directory cache in fontconfig for /usr/share/fonts seems broken. it doesn't contain one for Lohit Tamil. once rerun fc-cache -f /usr/share/fonts (after copying fc-cache from somewhere else) it works again.
Comment 9 Pravin Satpute 2013-10-01 02:59:02 EDT
(In reply to Akira TAGOH from comment #8)
> I'm not quite sure why/how it happened but the directory cache in fontconfig
> for /usr/share/fonts seems broken. it doesn't contain one for Lohit Tamil.
> once rerun fc-cache -f /usr/share/fonts (after copying fc-cache from
> somewhere else) it works again.

I remember same issue was there with Malayalam during Fedora 19 release. Font was installed but it was not present in font cache.  https://bugzilla.redhat.com/show_bug.cgi?id=995788

Though not able to reproduce same later on.
Comment 12 Akira TAGOH 2013-10-16 23:29:30 EDT
*** Bug 1014988 has been marked as a duplicate of this bug. ***
Comment 15 Ludek Smid 2014-06-13 09:20:38 EDT
This request was resolved in Red Hat Enterprise Linux 7.0.

Contact your manager or support representative in case you have further questions about the request.

Note You need to log in before you can comment on or make changes to this bug.