Bug 1011528 - Default Environment selection for user doesn't let you select a content view
Default Environment selection for user doesn't let you select a content view
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Content Management (Show other bugs)
6.0.2
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Eric Helms
Corey Welton
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-24 09:34 EDT by Mike McCune
Modified: 2014-04-24 13:11 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mike McCune 2013-09-24 09:34:58 EDT
Our current widget on the User's "Defaults" setting only allows you to specify an Environment.

Now that we require Content Views this needs to also expand to include a CV as a selection option.
Comment 3 Mike McCune 2013-11-05 22:05:05 EST
https://github.com/Katello/katello/pull/3293
Comment 4 Mike McCune 2013-11-06 09:37:44 EST
https://github.com/Katello/katello-cli/pull/119
Comment 7 Corey Welton 2013-11-07 01:44:24 EST
This bug is confusing me.

The subject line of the bug indicates that I should be looking for a way to select a content view in the  user defaults

Unless I'm missing something, I don't see this in Satellite-6.0.2-RHEL-6-20131106.0  It's not 100% clear where exactly I am looking for this, but I have looked in the following locations:

$user > My Account > Defaults
Administer > Users > $user > Defaults
Administer > Users > +New User > System Registration Defaults (note - this is after choosing an org and environment)

That said...

The text of the pull request reads:
"When content views were added, the default environment functionality
broke from the UI perspective since a user would need to select both
an environment and a content view. To simplify this interaction the
default environment selection was removed and replaced by choosing
just a default organization."

I take this to mean that (something??) was scrapped, whereupon we now only select a Default Org. In this specific scenario, we're good when editing the defaults for a user.

When we are _creating_ a user,  however, we're still given the option for selecting a default environment (after choosing an org).

TBH I'm not sure if
a) we're supposed to be able to choose a content view
b) we're supposed to only be able to select a default org
c) whether the imposed limitation of being only able to select a default org should apply to when users are being created.


Please clarify, QE will test when we're sure of what the expected behavior should be.
Comment 8 Mike McCune 2013-11-07 09:24:53 EST
You *just* select a default org which simplifies org faving in the drop list and dumps systems in the Default Environment View.

The bug is a bit confusing because we changed it up during implementation somewhat to only selecting an org but *not* a content view, you just get the Default.
Comment 9 Corey Welton 2013-11-07 10:04:17 EST
QA Verified for questions a) and b) above.  Per mmccune, c) is being written up as a new BZ - no reason to allow selection of an environment at user creation if it can't be changed later with this new workflow.

Satellite-6.0.2-RHEL-6-20131106.0
Comment 10 Bryan Kearney 2014-04-24 13:10:54 EDT
This was verified and delivered with MDP2. Closing it out.
Comment 11 Bryan Kearney 2014-04-24 13:11:58 EDT
This was delivered and verified with MDP2. Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.