Bug 1011588 - sandboxes terminate quickly after upgrade to 2.1.14-46.5
sandboxes terminate quickly after upgrade to 2.1.14-46.5
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: policycoreutils (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
:
: 1013273 (view as bug list)
Depends On:
Blocks: 1029624
  Show dependency treegraph
 
Reported: 2013-09-24 11:08 EDT by John T. Rose
Modified: 2013-11-12 13:54 EST (History)
7 users (show)

See Also:
Fixed In Version: policycoreutils-2.1.14-46.6.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
: 1029624 (view as bug list)
Environment:
Last Closed: 2013-10-08 07:25:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John T. Rose 2013-09-24 11:08:16 EDT
Description of problem:

After updating policycoreutils, policycoreutils-python and policycoreutils-sandbox to 2.1.14-46.5 all sandboxes seem to die quickly without output.

Reverting these packages to 2.1.14-45 restores working sandboxes.

Version-Release number of selected component (if applicable):

policycoreutils-sandbox-2.1.14-46.5.fc19.i686
policycoreutils-2.1.14-46.5.fc19.i686
policycoreutils-python-2.1.14-46.5.fc19.i686

How reproducible:

Duplicated on multiple machines.

Steps to Reproduce:
1. Upgrade to 2.1.14-46.5
2. sandbox -X firefox

Actual results:

Quietly returns almost instantly without opening firefox.

Expected results:

Runs firefox in a sandbox.

Additional info:
Comment 1 Daniel Walsh 2013-09-24 11:53:18 EDT
Could you try 

# chmod 4755 /usr/sbin/seunshare

And see if this fixes the problem?
Comment 2 John T. Rose 2013-09-24 12:01:47 EDT
yes, it does fix the problem.
Comment 3 Daniel Walsh 2013-09-24 12:24:52 EDT
Ok there seems to be some new file capability that we currently do not allow.
Comment 4 Daniel Walsh 2013-09-24 15:35:12 EDT
*** Bug 986079 has been marked as a duplicate of this bug. ***
Comment 5 Amit Shah 2013-09-30 00:24:39 EDT
*** Bug 1013273 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2013-10-04 15:07:58 EDT
policycoreutils-2.1.14-46.6.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/policycoreutils-2.1.14-46.6.fc19
Comment 7 Fedora Update System 2013-10-05 21:35:53 EDT
Package policycoreutils-2.1.14-46.6.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing policycoreutils-2.1.14-46.6.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-18394/policycoreutils-2.1.14-46.6.fc19
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2013-10-08 07:25:04 EDT
policycoreutils-2.1.14-46.6.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.