Bug 1011628 - packstack reports installation completed successfully but nothing installed
packstack reports installation completed successfully but nothing installed
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: openstack-packstack (Show other bugs)
unspecified
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ivan Chavero
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-24 12:26 EDT by Robin Goldstone
Modified: 2016-04-26 18:53 EDT (History)
7 users (show)

See Also:
Fixed In Version: openstack-packstack-2013.2.1-0.36.dev1013.el6.noarch
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-30 19:04:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
logs from debug packstack installation (12.96 KB, application/x-gzip)
2013-09-24 14:14 EDT, Robin Goldstone
no flags Details

  None (edit)
Description Robin Goldstone 2013-09-24 12:26:49 EDT
Description of problem:
I am trying to install RDO on a cluster that is running RHEL 6.4. It is not entirely stock but rather a modified distro that is tailored to our environment. I attempted to follow the Quickstart instructions which resulted in what appeared to be a successful installation:

# brutus2 /home/robing/rdo > yum install -y http://rdo.fedorapeople.org/openstack/openstack-grizzly/rdo-release-grizzly.rpm
Loaded plugins: changelog, ps, refresh-packagekit, security
file:///repo/toss/current/x86_64/repodata/repomd.xml: [Errno 14] Could not open/read file:///repo/toss/current/x86_64/repodata/repomd.xml
Trying other mirror.
TOSS                                                                                             | 3.6 kB     00:00     
TOSS/primary_db                                                                                  | 2.4 MB     00:00     
epel/metalink                                                                                    |  13 kB     00:00     
epel                                                                                             | 4.2 kB     00:00     
epel/primary_db                                                                                  | 5.6 MB     00:00     
Setting up Install Process
rdo-release-grizzly.rpm                                                                          | 7.4 kB     00:00     
Examining /var/tmp/yum-root-Km2rlg/rdo-release-grizzly.rpm: rdo-release-grizzly-3.noarch
Marking /var/tmp/yum-root-Km2rlg/rdo-release-grizzly.rpm to be installed
Resolving Dependencies
--> Running transaction check
---> Package rdo-release.noarch 0:grizzly-3 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

========================================================================================================================
 Package                    Arch                  Version                     Repository                           Size
========================================================================================================================
Installing:
 rdo-release                noarch                grizzly-3                   /rdo-release-grizzly                3.3 k

Transaction Summary
========================================================================================================================
Install       1 Package(s)

Total size: 3.3 k
Installed size: 3.3 k
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Warning: RPMDB altered outside of yum.
  Installing : rdo-release-grizzly-3.noarch                                                                         1/1 
  Verifying  : rdo-release-grizzly-3.noarch                                                                         1/1 

Installed:
  rdo-release.noarch 0:grizzly-3                                                                                        

Complete!
# brutus2 /root > yum install -y openstack-packstack
Loaded plugins: changelog, priorities, ps, refresh-packagekit, security
73 packages excluded due to repository priority protections
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package openstack-packstack.noarch 0:2013.1.1-0.29.dev683.el6 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

========================================================================================================================
 Package                       Arch             Version                               Repository                   Size
========================================================================================================================
Installing:
 openstack-packstack           noarch           2013.1.1-0.29.dev683.el6              openstack-grizzly           602 k

Transaction Summary
========================================================================================================================
Install       1 Package(s)

Total download size: 602 k
Installed size: 1.8 M
Downloading Packages:
openstack-packstack-2013.1.1-0.29.dev683.el6.noarch.rpm                                          | 602 kB     00:00     
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Warning: RPMDB altered outside of yum.
  Installing : openstack-packstack-2013.1.1-0.29.dev683.el6.noarch                                                  1/1 
  Verifying  : openstack-packstack-2013.1.1-0.29.dev683.el6.noarch                                                  1/1 

Installed:
  openstack-packstack.noarch 0:2013.1.1-0.29.dev683.el6                                                                 

Complete!
# brutus2 /root > 
# brutus2 /home/robing/rdo > packstack --allinone --os-quantum-install=n
Welcome to Installer setup utility

Installing:
Clean Up...                                            [ DONE ]
Setting up ssh keys...                                 [ DONE ]
Adding pre install manifest entries...                 [ DONE ]
Adding MySQL manifest entries...                       [ DONE ]
Adding QPID manifest entries...                        [ DONE ]
Adding Keystone manifest entries...                    [ DONE ]
Adding Glance Keystone manifest entries...             [ DONE ]
Adding Glance manifest entries...                      [ DONE ]
Adding Cinder Keystone manifest entries...             [ DONE ]
Installing dependencies for Cinder...                  [ DONE ]
Checking if the Cinder server has a cinder-volumes vg...[ DONE ]
Adding Cinder manifest entries...                      [ DONE ]
Adding Nova API manifest entries...                    [ DONE ]
Adding Nova Keystone manifest entries...               [ DONE ]
Adding Nova Cert manifest entries...                   [ DONE ]
Adding Nova Conductor manifest entries...              [ DONE ]
Adding Nova Compute manifest entries...                [ DONE ]
Adding Nova Scheduler manifest entries...              [ DONE ]
Adding Nova VNC Proxy manifest entries...              [ DONE ]
Adding Nova Common manifest entries...                 [ DONE ]
Adding Nova Network manifest entries...                [ DONE ]
Adding OpenStack Client manifest entries...            [ DONE ]
Adding Horizon manifest entries...                     [ DONE ]
Adding Swift Keystone manifest entries...              [ DONE ]
Adding Swift builder manifest entries...               [ DONE ]
Adding Swift proxy manifest entries...                 [ DONE ]
Adding Swift storage manifest entries...               [ DONE ]
Adding Swift common manifest entries...                [ DONE ]
Preparing servers...                                   [ DONE ]
Adding Nagios server manifest entries...               [ DONE ]
Adding Nagios host manifest entries...                 [ DONE ]
Adding post install manifest entries...                [ DONE ]
Installing Dependencies...                             [ DONE ]
Copying Puppet modules and manifests...                [ DONE ]
Applying Puppet manifests...
Applying 192.168.95.35_prescript.pp
192.168.95.35_prescript.pp :                                         [ DONE ]
Applying 192.168.95.35_mysql.pp
Applying 192.168.95.35_qpid.pp
192.168.95.35_mysql.pp :                                             [ DONE ]
192.168.95.35_qpid.pp :                                              [ DONE ]
Applying 192.168.95.35_keystone.pp
Applying 192.168.95.35_glance.pp
Applying 192.168.95.35_cinder.pp
192.168.95.35_keystone.pp :                                          [ DONE ]
192.168.95.35_cinder.pp :                                            [ DONE ]
192.168.95.35_glance.pp :                                            [ DONE ]
Applying 192.168.95.35_api_nova.pp
192.168.95.35_api_nova.pp :                                          [ DONE ]
Applying 192.168.95.35_nova.pp
Applying 192.168.95.35_osclient.pp
Applying 192.168.95.35_horizon.pp
192.168.95.35_nova.pp :                                              [ DONE ]
192.168.95.35_horizon.pp :                                           [ DONE ]
192.168.95.35_osclient.pp :                                          [ DONE ]
Applying 192.168.95.35_ring_swift.pp
192.168.95.35_ring_swift.pp :                                        [ DONE ]
Applying 192.168.95.35_swift.pp
Applying 192.168.95.35_nagios.pp
Applying 192.168.95.35_nagios_nrpe.pp
192.168.95.35_swift.pp :                                             [ DONE ]
192.168.95.35_nagios_nrpe.pp :                                       [ DONE ]
192.168.95.35_nagios.pp :                                            [ DONE ]
Applying 192.168.95.35_postscript.pp
192.168.95.35_postscript.pp :                                        [ DONE ]
                           [ DONE ]

 **** Installation completed successfully ******


Additional information:
 * A new answerfile was created in: /root/packstack-answers-20130923-155141.txt
 * Time synchronization installation was skipped. Please note that unsynchronized time on server instances might be problem for some OpenStack components.
 * Did not create a cinder volume group, one already existed
 * To use the command line tools you need to source the file /root/keystonerc_admin created on 192.168.95.35
 * To use the console, browse to http://192.168.95.35/dashboard
 * To use Nagios, browse to http://192.168.95.35/nagios username : nagiosadmin, password : 7fb16e4ee14c4c66
 * The installation log file is available at: /var/tmp/packstack/20130923-155141-gIO2zs/openstack-setup.log

However, nothing was actually set up. None of the openstack RPMs are installed, none of the files mentioned above are present e.g. no keystonerc_admin file, no Horizon dashboard, etc.  This appears to be due to the fact that puppet is not installed on my system.  I reported this on the RDO forum and was told that packstack should install puppet if it is not already installed yet it is not doing that.  Here is one of the packstack puppet log files which makes it appear that puppet ran successfully.  However, you can see that puppet is not even installed.

# brutus2 /var/tmp/packstack/20130923-155141-gIO2zs/manifests > cat 192.168.95.35_api_nova.pp.log 
flock: puppet: Success
# brutus2 /var/tmp/packstack/20130923-155141-gIO2zs/manifests > which puppet
/usr/bin/which: no puppet in (/usr/lib64/qt-3.3/bin:/admin/bin:/admin/sbin:/admin/scripts:/sbin:/bin:/usr/sbin:/usr/bin)
# brutus2 /var/tmp/packstack/20130923-155141-gIO2zs/manifests > rpm -qa|grep puppet
# brutus2 /var/tmp/packstack/20130923-155141-gIO2zs/manifests > 

I have found that if I manually install puppet, I can re-run packstack and it proceeds with the installation.  So is puppet a prerequisite for installing RDO?
If so, that ought to be stated up front.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Perry Myers 2013-09-24 12:33:20 EDT
Robin, can you please attach the log file from packstack to the bugzilla?  And can you include in a comment the RDO discussion thread where you originally reported this issue?
Comment 2 Martin Magr 2013-09-24 12:43:08 EDT
This is weird, the only way how packstack won't fail without puppet is that the puppet installation (yum install -y puppet) failed but reported success
Comment 3 Martin Magr 2013-09-24 12:45:27 EDT
Or puppet RPM is installed but manually deleted, so Packstack thinks it is installed.
Comment 4 Robin Goldstone 2013-09-24 12:47:46 EDT
Hi Perry,

I  reported this to the RDO forum here:
http://openstack.redhat.com/forum/discussion/512/rdo-install-completes-successfully-but-does-nothing/p1

Note when I initially tried the install, my system did not have the EPEL repository set up in yum, which they speculated might be the issue.  However, this time around I have EPEL properly configured.

Here is the openstack log file.  It is short so I am putting it inline.
# brutus2 /var/tmp/packstack/20130923-155141-gIO2zs > cat openstack-setup.log 
2013-09-23 15:51:41::INFO::run_setup::399::root:: A new answerfile was created in: /root/packstack-answers-20130923-155141.txt
2013-09-23 15:51:41::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'yes', and match: 'yes'
2013-09-23 15:51:41::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'yes', and match: 'yes'
2013-09-23 15:51:41::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'yes', and match: 'yes'
2013-09-23 15:51:41::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'y', and match: 'y'
2013-09-23 15:51:41::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'yes', and match: 'yes'
2013-09-23 15:51:41::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'y', and match: 'y'
2013-09-23 15:51:41::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'y', and match: 'y'
2013-09-23 15:51:41::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'True', and match: 'True'
2013-09-23 15:51:41::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'y', and match: 'y'
2013-09-23 15:51:41::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'True', and match: 'True'
2013-09-23 15:51:41::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'n', and match: 'y'
2013-09-23 15:51:41::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'False', and match: 'True'
2013-09-23 15:51:41::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'False', and match: 'True'
2013-09-23 15:51:41::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'y', and match: 'y'
2013-09-23 15:51:41::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'y', and match: 'y'
2013-09-23 15:51:41::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'n', and match: 'y'
2013-09-23 15:51:41::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'y', and match: 'y'
2013-09-23 15:51:41::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'False', and match: 'True'
2013-09-23 15:51:41::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'False', and match: 'True'
2013-09-23 15:51:41::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'False', and match: 'True'
2013-09-23 15:51:41::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'yes', and match: 'yes'
2013-09-23 15:51:41::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'yes', and match: 'yes'
2013-09-23 15:51:41::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'False', and match: 'True'
2013-09-23 15:51:41::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'False', and match: 'True'
2013-09-23 15:51:41::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'y', and match: 'y'
2013-09-23 15:51:41::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'yes', and match: 'yes'
2013-09-23 15:51:41::INFO::run_setup::359::root:: Comparing pre- conditions, value: 'yes', and match: 'yes'
2013-09-23 15:52:04::INFO::run_setup::598::root:: Removing /var/tmp/packstack/7eddf76994114d0083a875ed5b7b699f on 192.168.95.35 (if it is a remote host)
2013-09-23 15:52:04::INFO::run_setup::532::root::  * A new answerfile was created in: /root/packstack-answers-20130923-155141.txt
2013-09-23 15:52:04::INFO::run_setup::532::root::  * Time synchronization installation was skipped. Please note that unsynchronized time on server instances might be problem for some OpenStack components.
2013-09-23 15:52:04::INFO::run_setup::532::root::  * Did not create a cinder volume group, one already existed
2013-09-23 15:52:04::INFO::run_setup::532::root::  * To use the command line tools you need to source the file /root/keystonerc_admin created on 192.168.95.35
2013-09-23 15:52:04::INFO::run_setup::532::root::  * To use the console, browse to http://192.168.95.35/dashboard
2013-09-23 15:52:04::INFO::run_setup::532::root::  * To use Nagios, browse to http://192.168.95.35/nagios username : nagiosadmin, password : 7fb16e4ee14c4c66
2013-09-23 15:52:04::INFO::run_setup::532::root::  * The installation log file is available at: /var/tmp/packstack/20130923-155141-gIO2zs/openstack-setup.log
# brutus2 /var/tmp/packstack/20130923-155141-gIO2zs >
Comment 5 Robin Goldstone 2013-09-24 12:52:10 EDT
Hi Martin,

puppet has never been installed on this system.  Note we are not running "vanilla" RHEL but rather a customized distribution.  We maintain our own repo and do not pull from public RHEL repos with the exception of EPEL, which I have set up for this project.  It appears that puppet is available in the EPEL repo so packstack should be able to install it:
# brutus2 /var/tmp/packstack/20130923-155141-gIO2zs > yum list puppet
Loaded plugins: changelog, priorities, ps, refresh-packagekit, security
73 packages excluded due to repository priority protections
Available Packages
puppet.noarch                                             2.6.18-3.el6                                              epel
# brutus2 /var/tmp/packstack/20130923-155141-gIO2zs > 

I can try the manual yum install of puppet if you want.
-Robin
Comment 6 Martin Magr 2013-09-24 13:07:27 EDT
It would be more useful if you would run packstack with --debug switch and attach tarball of /var/tmp/packstack to this bug.
Comment 7 Robin Goldstone 2013-09-24 14:14:55 EDT
Created attachment 802417 [details]
logs from debug packstack installation
Comment 8 Robin Goldstone 2013-09-25 15:09:42 EDT
OK here is some progress.  Per discussion on my other bugzilla, I am now pointing to our RHEL satellite in addition to TOSS.  I am now getting MUCH farther (but still failing, see below) including successful installation of puppet.  One thing in particular I noted is that the step:
Installing Dependencies...                             [ DONE ]

took a lot longer than it has in the past.  It seems like potentially when I didn't include the RHEL repo, this step was not successfully installing all the dependencies yet it seemingly completed with a successful return code.  So that might be something to look at.  However, as I stated in my original post to the RDO forum, even if packstack didn't detect that the puppet installation had failed, it should still fail when it tries to run puppet, since any invocation of puppet would fail.  So it does not seem like you are checking return codes on every command you run.

That is just my $0.02.

As mentioned above, I am now getting farther but still failing.  The reason is it tried to install qemu-kvm but failed because we have our own modified version of this RPM:
# brutus3 /root > rpm -q qemu-kvm
package qemu-kvm is not installed
# brutus3 /root > rpm -qa|grep qemu-kvm
qemu-kvm-rhev-0.12.1.2-2.355.ch5.1.x86_64

I need to figure out how to resolve this conflict.  But clearly having access to the RHEL repo made things work better.  It is just a question of why packstack didn't report any errors when it couldn't install puppet.

Regards,
Robin
Comment 9 Ivan Chavero 2014-04-29 00:28:56 EDT
Tested and this problem does not appear anymore:

Removed puppet:
yum erase -y puppet

packstack  -d --answer-file=packstack-answers-20140428-194248.txt

...

Adding Nagios host manifest entries                  [ DONE ]
Adding post install manifest entries                 [ DONE ]
Preparing servers                                    [ DONE ]
Installing Dependencies                           [ ERROR ]

ERROR : Failed to run remote script, stdout: no package provides puppet
Loaded plugins: product-id, subscription-manager
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package puppet.noarch 0:3.5.1-1.el6 will be installed
--> Processing Dependency: facter >= 1:1.7.0 for package: puppet-3.5.1-1.el6.noarch
--> Processing Dependency: hiera >= 1.0.0 for package: puppet-3.5.1-1.el6.noarch
--> Processing Dependency: ruby-rgen >= 0.6.5 for package: puppet-3.5.1-1.el6.noarch
--> Processing Dependency: rubygem-json for package: puppet-3.5.1-1.el6.noarch
--> Running transaction check
---> Package facter.x86_64 0:1.6.18-3.el6 will be updated
---> Package facter.x86_64 1:2.0.1-1.el6 will be an update
---> Package hiera.noarch 0:1.3.2-1.el6 will be installed
---> Package ruby-rgen.noarch 0:0.6.5-2.el6 will be installed
---> Package rubygem-json.x86_64 0:1.5.5-1.el6 will be installed
--> Processing Dependency: rubygems for package: rubygem-json-1.5.5-1.el6.x86_64
--> Finished Dependency Resolution
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

stderr: Warning: Permanently added '192.168.100.210' (RSA) to the list of known hosts.
+ trap t ERR
+ rpm -q --whatprovides puppet
+ yum install -y puppet
Error: Package: rubygem-json-1.5.5-1.el6.x86_64 (puppetlabs-deps)
           Requires: rubygems
++ t
++ exit 1

Note You need to log in before you can comment on or make changes to this bug.