Bug 1011703 - Auto-Attach subscriptions displayed in register dialog should not be "selectable" and the table in which it is displayed requires a table name (AT-SPI Locator)
Auto-Attach subscriptions displayed in register dialog should not be "select...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Michael Stead
John Sefler
:
Depends On:
Blocks: rhsm-rhel65
  Show dependency treegraph
 
Reported: 2013-09-24 17:26 EDT by Sharath Dwaral
Modified: 2015-03-22 21:14 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
No description necessary
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 16:30:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
auto attach subscription selectable (204.23 KB, image/png)
2013-09-24 17:26 EDT, Sharath Dwaral
no flags Details
auto-attach-product-display-window (295.71 KB, image/png)
2013-10-07 19:41 EDT, Sharath Dwaral
no flags Details

  None (edit)
Description Sharath Dwaral 2013-09-24 17:26:14 EDT
Created attachment 802498 [details]
auto attach subscription selectable

Description of problem:
Auto-Attach  subscriptions displayed in register dialog should not be "selectable". If there were to be more than one product displayed in the table, it would give a perception that we are choosing what we want to attach since we can select/highlight a particular row.

Version-Release number of selected component (if applicable):
# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-1.9.7-1.el6.x86_64
subscription-manager-migration-1.9.7-1.el6.x86_64
subscription-manager-firstboot-1.9.7-1.el6.x86_64
python-rhsm-debuginfo-1.9.6-1.el6.x86_64
subscription-manager-debuginfo-1.9.7-1.el6.x86_64
python-rhsm-1.9.6-1.el6.x86_64
subscription-manager-gui-1.9.7-1.el6.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Register system to candlepin
2. Click Auto-Attach
3. Choose SLA click Next
4. See Attachment

Actual results:
See Attachment

Expected results:
Would prefer this table to be used only for displaying the subscriptions without the option to highlight/select the rows being displayed. Similar to "Products" in "Subscription Details" displayed in "All Available Subscription".

Also would want the table to have a name right now it has no-name. This is for the sake of AT-SPI locator  :)

Additional info:
Comment 1 Sharath Dwaral 2013-09-24 17:29:31 EDT
With the changes suggested I think the table would no longer be "sortable" on columns.  I'm not sue though
Comment 2 Michael Stead 2013-09-25 09:45:29 EDT
Disabling selection on the table does not disable sorting on the table. Will enabled sorting cause you issues when testing?
Comment 3 Michael Stead 2013-10-03 11:47:49 EDT
Fixed in master 5d7d98fe64867d16a04defaada898568de0a9918

Avaliable in subscription-manager-1.10.3-1+
Comment 6 Sharath Dwaral 2013-10-07 19:41:30 EDT
Created attachment 809028 [details]
auto-attach-product-display-window

Version:

Tested on stage

# subscription-manager version 
server type: Red Hat Subscription Management
subscription management server: Unknown
subscription-manager: 1.9.9-1.el6
python-rhsm: 1.9.6-1.el6

Verification see attachment.  

The products are no longer selectable and the table can still be sored

VERIFIED
Comment 8 errata-xmlrpc 2013-11-21 16:30:10 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1659.html

Note You need to log in before you can comment on or make changes to this bug.