Bug 1011721 - haproxy set-proxy hook fails frequently leading to incorrect haproxy.cfg file
haproxy set-proxy hook fails frequently leading to incorrect haproxy.cfg file
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Michal Fojtik
libra bugs
: TestBlocker
: 1011766 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-24 20:29 EDT by Mrunal Patel
Modified: 2015-05-14 19:29 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-17 09:31:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mrunal Patel 2013-09-24 20:29:56 EDT
Description of problem:
Creating scalable apps is failing most of the times with this error.

I, [2013-09-24T20:25:41.051835 #1107]  INFO -- : openshift.rb:202:in `execute_parallel_action' execute_parallel_action call - [{:tag=>"", :gear=>"52422d666e86d47aa3000004", :job=>{:cartridge=>"openshift-origin-node", :action=>"connector-execute", :args=>{"--with-app-uuid"=>"52422d666e86d47aa3000004", "--with-app-name"=>"php1", "--with-container-uuid"=>"52422d666e86d47aa3000004", "--with-container-name"=>"php1", "--with-namespace"=>"testip", "--with-request-id"=>"836967d7fcd4ee3fc0626ecf1897a049", "--cart-name"=>"haproxy-1.4", "--component-name"=>"web_proxy", "--with-software-version"=>"1.4", "--cartridge-vendor"=>"redhat", "--hook-name"=>"set-proxy", "--publishing-cart-name"=>"php-5.3", "--connection-type"=>"NET_TCP:httpd-proxy-info", "--input-args"=>"php1 testip 52422d666e86d47aa3000004 \\'52422d666e86d47aa3000004\\'\\=\\'php1-testip.dev.rhcloud.com\\|10.147.163.110:38031'\n'\\'"}}, :result_stdout=>"Control action 'set-proxy' returned an error. rc=1\n\n\n/usr/lib/openshift/cartridge_sdk/ruby/sdk.rb:20:in `<module:OpenShift>': Cartridge is not a module (TypeError)\n\tfrom /usr/lib/openshift/cartridge_sdk/ruby/sdk.rb:19:in `<top (required)>'\n\tfrom /opt/rh/ruby193/root/usr/share/rubygems/rubygems/custom_require.rb:36:in `require'\n\tfrom /opt/rh/ruby193/root/usr/share/rubygems/rubygems/custom_require.rb:36:in `require'\n", :result_stderr=>"", :result_exit_code=>1}, {:tag=>"", :gear=>"52422d666e86d47aa3000004", :job=>{:cartridge=>"openshift-origin-node", :action=>"connector-execute", :args=>{"--with-app-uuid"=>"52422d666e86d47aa3000004", "--with-app-name"=>"php1", "--with-container-uuid"=>"52422d666e86d47aa3000004", "--with-container-name"=>"php1", "--with-namespace"=>"testip", "--with-request-id"=>"836967d7fcd4ee3fc0626ecf1897a049", "--cart-name"=>"haproxy-1.4", "--component-name"=>"web_proxy", "--with-software-version"=>"1.4", "--cartridge-vendor"=>"redhat", "--hook-name"=>"set-gear-endpoints", "--publishing-cart-name"=>"php-5.3", "--connection-type"=>"NET_TCP:gear-endpoint-info", "--input-args"=>"php1 testip 52422d666e86d47aa3000004 \\'52422d666e86d47aa3000004\\'\\=\\'52422d666e86d47aa3000004@10.147.163.110:php\\;php1-testip.dev.rhcloud.com\\'"}}, :result_stdout=>"", :result_stderr=>"", :result_exit_code=>0}, {:tag=>"", :gear=>"52422d666e86d47aa3000004", :job=>{:cartridge=>"openshift-origin-node", :action=>"connector-execute", :args=>{"--with-app-uuid"=>"52422d666e86d47aa3000004", "--with-app-name"=>"php1", "--with-container-uuid"=>"52422d666e86d47aa3000004", "--with-container-name"=>"php1", "--with-namespace"=>"testip", "--with-request-id"=>"836967d7fcd4ee3fc0626ecf1897a049", "--cart-name"=>"haproxy-1.4", "--component-name"=>"web_proxy", "--with-software-version"=>"1.4", "--cartridge-vendor"=>"redhat", "--hook-name"=>"set-haproxy-status-url", "--publishing-cart-name"=>"haproxy-1.4", "--connection-type"=>"NET_TCP:haproxy-status-info", "--input-args"=>"php1 testip 52422d666e86d47aa3000004 \\'52422d666e86d47aa3000004\\'\\=\\'http://php1-testip.dev.rhcloud.com/haproxy-status/'\n'\\'"}}, :result_stdout=>"", :result_stderr=>"", :result_exit_code=>0}]


Version-Release number of selected component (if applicable):


How reproducible:
Frequently.

Steps to Reproduce:
1. Create a scalable app.
2. Access haproxy-status url. (It will be missing some gears).
3. Check /var/log/ruby193-mcollective.log to see the failure above.
Comment 1 Michal Fojtik 2013-09-25 08:53:33 EDT
Hi Mrunal,

I have fix for this here:

https://github.com/openshift/origin-server/pull/3703
Comment 2 Mrunal Patel 2013-09-25 12:17:24 EDT
*** Bug 1011766 has been marked as a duplicate of this bug. ***
Comment 3 openshift-github-bot 2013-09-25 13:46:09 EDT
Commit pushed to master at https://github.com/openshift/origin-server

https://github.com/openshift/origin-server/commit/8192149a38ad1cc1ec6ff9007f24d43e61b6decd
Bug 1011721- Fixed wrong namespace for Cartridge Ruby SDK
Comment 4 Meng Bo 2013-09-26 06:08:11 EDT
Checked on devenv_3829,

After create the scalable app, the haproxy.cfg contain the local-gear info, the app can be visited, the haproxy_ctld is running well and can auto-scaling, there is no such error in ruby193-mcollective.log.

Move bug to verified.

Note You need to log in before you can comment on or make changes to this bug.