Bug 1011727 - hwcert-client package should require usbutils for /usr/bin/lsusb
hwcert-client package should require usbutils for /usr/bin/lsusb
Status: CLOSED WONTFIX
Product: Red Hat Hardware Certification Program
Classification: Red Hat
Component: Test Suite (tests) (Show other bugs)
1.7.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Greg Nichols
Pavel Stehlik
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-24 21:33 EDT by Greg Nichols
Modified: 2015-07-13 09:56 EDT (History)
4 users (show)

See Also:
Fixed In Version: hwcert-client 1.7.0-61
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-13 09:56:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
spec file patch requiring usbutils except on s390x (802 bytes, patch)
2013-10-09 21:26 EDT, Greg Nichols
no flags Details | Diff

  None (edit)
Description Greg Nichols 2013-09-24 21:33:26 EDT
Description of problem:

hwcert-client uses the lsusb command from the usbutils package.   The hwcert-client package should add a Requires for usbutils.


Version-Release number of selected component (if applicable):

hwcert-client 1.7.0 R55
Comment 1 Greg Nichols 2013-09-30 10:02:21 EDT
s390x does not have usbutils.   It looks like we need a plan-time requires for the usb test that makes an exception of s390x.
Comment 2 Greg Nichols 2013-10-09 21:26:28 EDT
Created attachment 810235 [details]
spec file patch requiring usbutils except on s390x
Comment 5 Petr Beňas 2013-10-22 11:06:33 EDT
Reproduced in hwcert-client-1.7.0-60.el7 and verified in hwcert-client-1.7.0-61.el7.
Comment 8 brose 2015-07-13 09:56:52 EDT
Closing as hwcert-client is obsolete.
Please use redhat-certification-hardware instead.

Note You need to log in before you can comment on or make changes to this bug.