Bug 1011775 - RHS-C: rhsc-setup prompts for selecting the Application mode (Both, Virt, Gluster) [Both]
RHS-C: rhsc-setup prompts for selecting the Application mode (Both, Virt, Glu...
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
2.1
Unspecified Unspecified
medium Severity high
: ---
: RHGS 2.1.2
Assigned To: Darshan
Prasanth
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-25 02:44 EDT by Prasanth
Modified: 2015-05-13 12:31 EDT (History)
8 users (show)

See Also:
Fixed In Version: CB5
Doc Type: Bug Fix
Doc Text:
Previously, a prompt to select application mode was displayed while running rhsc-setup command. Now, with this update, the query for selecting application mode is removed from rhsc-setup and application mode is set to gluster and the prompt is not displayed.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:39:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Prasanth 2013-09-25 02:44:26 EDT
Description of problem: rhsc-setup prompts for selecting the Application mode (Both, Virt, Gluster) [Both]. See below:

-------------------------
[root@vm08 ]# rhsc-setup 
[ INFO  ] Stage: Initializing
[ INFO  ] Stage: Environment setup
          Configuration files: ['/etc/ovirt-engine-setup.conf.d/10-packaging.conf']
          Log file: /var/log/ovirt-engine/setup/ovirt-engine-setup-20130924184512.log
          Version: otopi-1.1.1 (otopi-1.1.1-1.el6ev)
[ INFO  ] Stage: Environment packages setup
[ INFO  ] Stage: Programs detection
[ INFO  ] Stage: Environment setup
[ INFO  ] Stage: Environment customization
         
          --== PACKAGES ==--
         
[ INFO  ] Checking for product updates...
[ INFO  ] No product updates found
         
          --== NETWORK CONFIGURATION ==--
         
          Host fully qualified DNS name of this server [vm08.lab.eng.blr.redhat.com]: 
          iptables was detected on your computer. Do you wish Setup to configure it? (yes, no) [yes]: 
         
          --== DATABASE CONFIGURATION ==--
         
          Where is the database located? (Local, Remote) [Local]: 
          Setup can configure the local postgresql server automatically for the engine to run. This may conflict with existing applications.
          Would you like Setup to automatically configure postgresql, or prefer to perform that manually? (Automatic, Manual) [Automatic]: 
          Using existing credentials
         
          --== OVIRT ENGINE CONFIGURATION ==--
         
          Engine admin password: 
          Confirm engine admin password: 
[WARNING] Password is weak: it is based on a dictionary word
          Use weak password? (Yes, No) [No]: Yes
          Application mode (Both, Virt, Gluster) [Both]: Gluster
         
          --== PKI CONFIGURATION ==--
         
          Organization name for certificate [lab.eng.blr.redhat.com]: Red Hat
         
          --== APACHE CONFIGURATION ==--
         
          Setup can configure the default page of the web server to present the application home page. This may conflict with existing applications.
          Do you wish to set the application as the default page of the web server? (Yes, No) [Yes]: 
          Setup can configure apache to use SSL using a certificate issued from the internal CA.
          Do you wish Setup to configure that, or prefer to perform that manually? (Automatic, Manual) [Automatic]: 
         
          --== SYSTEM CONFIGURATION ==--
         
[ INFO  ] NFS configuration skipped with application mode Gluster
         
          --== END OF CONFIGURATION ==--
         
[ INFO  ] Stage: Setup validation
[WARNING] Less than 16384MB of memory is available
         
          --== CONFIGURATION PREVIEW ==--
         
          Database name                      : engine
          Database secured connection        : False
          Database host                      : localhost
          Database user name                 : engine
          Database host name validation      : False
          Datbase port                       : 5432
          NFS setup                          : False
          PKI organization                   : Red Hat
          Application mode                   : gluster
          Firewall manager                   : iptables
          Host FQDN                          : vm08.lab.eng.blr.redhat.com
          Datacenter storage type            : nfs
          Configure local database           : True
          Set application as default page    : True
          Configure Apache SSL               : True
         
          Please confirm installation settings (OK, Cancel) [OK]: 
[ INFO  ] Stage: Transaction setup
[ INFO  ] Stopping engine service
[ INFO  ] Stage: Misc configuration
[ INFO  ] Stage: Package installation
[ INFO  ] Stage: Misc configuration
[ INFO  ] Initializing PostgreSQL
[ INFO  ] Creating PostgreSQL database
[ INFO  ] Configurating PostgreSQL
[ INFO  ] Creating database schema
[ INFO  ] Creating CA
[ INFO  ] Generating post install configuration file '/etc/ovirt-engine-setup.conf.d/20-setup-ovirt-post.conf'
[ INFO  ] Stage: Transaction commit
[ INFO  ] Stage: Closing up
         
          --== SUMMARY ==--
         
[WARNING] Less than 16384MB of memory is available
          SSH fingerprint: 80:2F:6D:8C:82:FF:61:B4:86:19:43:3B:0A:85:B7:A9
          Internal CA A6:22:41:87:3E:86:A1:AA:E3:51:B3:3D:DE:22:FD:B9:8C:E1:BA:6E
          Web access is enabled at:
              http://vm08.lab.eng.blr.redhat.com:80/ovirt-engine
              https://vm08.lab.eng.blr.redhat.com:443/ovirt-engine
          Please use the user "admin" and password specified in order to login into oVirt Engine
         
          --== END OF SUMMARY ==--
         
[ INFO  ] Starting engine service
[ INFO  ] Restarting httpd
[ INFO  ] Generating answer file '/var/lib/ovirt-engine/setup/answers/20130924184909-setup.conf'
[ INFO  ] Stage: Clean up
          Log file is located at /var/log/ovirt-engine/setup/ovirt-engine-setup-20130924184512.log
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ INFO  ] Execution of setup completed successfully
-------------------------

Version-Release number of selected component (if applicable):

----------------
rhsc-cli-.1.0.0-0.bb3a.el6rhs.noarch                                            
rhsc-lib-.1.1-0.0.1.master.el6ev.noarch                                         
rhsc-2.1.1-0.0.1.master.el6ev.noarch
rhsc-branding-rhs-3.3.0-1.0.master.201309200500.fc18.noarch                       
rhsc-sdk-2.1.0.0-0.bb3a.el6rhs.noarch
rhsc-webadmin-portal-2.1.1-0.0.1.master.el6ev.noarch
rhsc-restapi-2.1.1-0.0.1.master.el6ev.noarch
rhsc-backend-2.1.1-0.0.1.master.el6ev.noarch
rhsc-tools-2.1.1-0.0.1.master.el6ev.noarch
rhsc-setup-2.1.1-0.0.1.master.el6ev.noarch
rhsc-log-collector-2.1-0.1.el6rhs.noarch
rhsc-dbscripts-2.1.1-0.0.1.master.el6ev.noarch
----------------

How reproducible: Always


Steps to Reproduce:
1. Follow the instructions given in http://etherpad.corp.redhat.com/4jLzogeIgJ to setup engine
2. Run #rhsc-setup


Actual results: It prompts the user to select the following:

------
Application mode (Both, Virt, Gluster) [Both]: Gluster
------


Expected results: RHS-C downstream build always run only in Gluster only mode and hence no point in asking the user.


Additional info:
Comment 2 Prasanth 2013-10-28 08:52:12 EDT
Verified as fixed in cb5. 

It no longer asks for entering the Application mode.
Comment 3 Shalaka 2014-01-06 05:49:17 EST
Please review the edited DocText and confirm.
Comment 5 errata-xmlrpc 2014-02-25 02:39:43 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.