Bug 1011823 - asymptote spits out debug code "arc_ccw_turn, p=0" to the console
asymptote spits out debug code "arc_ccw_turn, p=0" to the console
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mesa-libGLU (Show other bugs)
19
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-25 04:15 EDT by maeshtro
Modified: 2013-12-19 20:34 EST (History)
2 users (show)

See Also:
Fixed In Version: mesa-libGLU-9.0.0-4.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-14 22:38:20 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description maeshtro 2013-09-25 04:15:20 EDT
Description of problem:

When running asymptote in interactive mode to create a 3D model, I get the following code in the console

arc_ccw_turn, p = 0
case a
arc_ccw_turn, p = 0
case c
arc_ccw_turn, p = 0
case b
arc_ccw_turn, p = 0
case d
...



Version-Release number of selected component (if applicable):

mesa-libGLU-9.0.0-2.fc19.x86_64


Steps to Reproduce:
1. # asy
2. > import three
3. > draw(unitbox)

Actual results:

Annoying debug messages appear on console

Expected results:

No debug code shows up.

Additional info:

This seems to be an old issue:

https://bugs.freedesktop.org/show_bug.cgi?id=61003

It is likely to be related to the mesa-libGLU libraries. The file ccw.cc in the sources contains the following code

#ifndef NDEBUG
    _glu_dprintf( "arc_ccw_turn, p = %d\n", 0 );
#endif
Comment 1 Fedora Update System 2013-12-09 11:38:18 EST
mesa-libGLU-9.0.0-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/mesa-libGLU-9.0.0-4.fc20
Comment 2 Fedora Update System 2013-12-09 11:46:34 EST
mesa-libGLU-9.0.0-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/mesa-libGLU-9.0.0-4.fc19
Comment 3 Fedora Update System 2013-12-09 15:26:02 EST
Package mesa-libGLU-9.0.0-4.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mesa-libGLU-9.0.0-4.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-23042/mesa-libGLU-9.0.0-4.fc20
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-12-14 22:38:20 EST
mesa-libGLU-9.0.0-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Fedora Update System 2013-12-19 20:34:47 EST
mesa-libGLU-9.0.0-4.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.