Bug 1011851 - Quickstarts examples' pom.xml files contain community repo dependencies
Quickstarts examples' pom.xml files contain community repo dependencies
Status: CLOSED NOTABUG
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Quickstarts (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity low
: ER5
: EAP 6.2.0
Assigned To: Paul Gier
Vladimir Rastseluev
Russell Dickenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-25 04:56 EDT by Vladimir Rastseluev
Modified: 2014-01-12 19:22 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-16 16:19:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vladimir Rastseluev 2013-09-25 04:56:17 EDT
Description of problem:
Quickstarts examples' pom.xml files contain community repo dependencies

Version-Release number of selected component (if applicable):
EAP 6.2.0 ER3

How reproducible:
easy

1) ejb-multi-server example pom.xml contains community <version.jboss.ejb.client> in artifact

2) 27 examples' (all kitchensink*, all tasks*) and root pom.xml contain community <version.jboss.bom.eap>6.2.0.Beta1</version.jboss.bom.eap> in artifacts
Comment 1 sgilda 2013-10-03 11:40:17 EDT
@vladimir rastseluev: 

1) I will change this to 1.0.23.Final-redhat-1

2) I only see this for all of them:  
   <version.jboss.bom.eap>6.2.0-build-SNAPSHOT</version.jboss.bom.eap>

Can you provide a direct Github link where you see this?
Comment 2 sgilda 2013-10-03 12:00:33 EDT
For 1): Issued pull: https://github.com/jboss-developer/jboss-eap-quickstarts/pull/643

For 2): Still need more info.
Comment 3 sgilda 2013-10-03 12:04:05 EDT
1) fixed upstream in master with this commit: 
https://github.com/jboss-developer/jboss-eap-quickstarts/commit/7def4d23064c3a4beccc5fcb6610c41c64a95295
Comment 4 Vladimir Rastseluev 2013-10-03 13:54:23 EDT
I see it in productized version. Probably <version.jboss.bom.eap>6.2.0-build-SNAPSHOT</version.jboss.bom.eap> is incorrect too. We need something like in added picketlink quickstarts examples(6.2.0-redhat-1).
Comment 5 sgilda 2013-10-03 16:00:49 EDT
I believe @rafaelbenevides said that 6.2.0=redhat-1 was used by mistake already. 

In email, @pmuir asked what version is being included in ER4? It should be that.

@vladimirrastseluev: Do you know what version is being used for ER4?
Comment 6 Vladimir Rastseluev 2013-10-03 22:23:21 EDT
In ER4 version of picketlink quickstarts <version.jboss.bom.eap>6.2.0.Beta1</version.jboss.bom.eap> is used
Comment 7 Vladimir Rastseluev 2013-10-04 02:03:00 EDT
See what it leads to: https://bugzilla.redhat.com/show_bug.cgi?id=1015393
Comment 8 Pete Muir 2013-10-04 05:56:57 EDT
Yes, I think this is a major problem. It looks like Paul Gier did not finish this before he went on PTO, and no one on the JBoss Developer team (Sande, me, Rafael) is clear what is plan was here.

Vaclav, do you know what the plan is, who would know, besides Paul?
Comment 9 sgilda 2013-10-04 07:21:54 EDT
Mark thinks Paul will return on Monday but is not sure.
Comment 10 sgilda 2013-10-08 11:59:02 EDT
@pgier: Can you tell me where this bug stands?
Comment 11 Vladimir Rastseluev 2013-10-10 07:49:48 EDT
EAP 6.2.0 ER5.1 quickstarts still contain wrong bom versions.
Comment 12 sgilda 2013-10-10 09:32:11 EDT
Vladimir: Can you be more specific? What should they be?

In the 6.2.x branch, they are: 
<version.jboss.bom.eap>6.2.0-build-SNAPSHOT</version.jboss.bom.eap>

I thought Paul's script changed that during the build.
Comment 13 Vladimir Rastseluev 2013-10-11 02:26:29 EDT
As I wrote in comment #4,  We need something like in added picketlink quickstarts examples(6.2.0-redhat-1).
Comment 14 sgilda 2013-10-11 08:53:44 EDT
I need Paul Gier for this one. As I said before, I thought his script modified these versions. I do not control the BOM versions in the 6.2.x branch.

Paul?
Comment 15 sgilda 2013-10-11 11:02:03 EDT
Reassigning to Paul since he knows what to do with this.
Comment 16 Paul Gier 2013-10-11 11:16:19 EDT
All the bom versions in ER5.1 are set to the correct version "6.2.0.Beta1" AFAICT.  The version "6.2.0.Beta1" is the product version available in the maven repo zip, not a community version.  The picketlink quickstarts were removed as part of bug 1015393.  Can you point to the specific poms which are incorrect?
Comment 17 Vladimir Rastseluev 2013-10-16 02:27:43 EDT
Only poms, containing "6.2.0.Beta1" IMO are incorrect. If it's a correct product version, please close this bug.
Comment 18 Paul Gier 2013-10-16 16:19:17 EDT
Closing this because the BOM versions were intentionally set to match the product release version.

Note You need to log in before you can comment on or make changes to this bug.