Bug 1011854 - UI doesn't refreshes the rule tab in first click after defining the filter rules
UI doesn't refreshes the rule tab in first click after defining the filter rules
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
Nightly
Unspecified Unspecified
medium Severity unspecified (vote)
: Unspecified
: --
Assigned To: Brad Buckingham
Sachin Ghai
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-25 04:57 EDT by Sachin Ghai
Modified: 2014-04-24 13:12 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed:
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rules are correctly displayed (53.21 KB, image/png)
2013-10-21 05:59 EDT, Sachin Ghai
no flags Details

  None (edit)
Description Sachin Ghai 2013-09-25 04:57:05 EDT
Description of problem:
When you create a filter and defines some rules, UI doesn't refreshes the rules under rules-tab. Instead of showing created rule, it shows

"This filter does not currently have any repositories assigned. Please add one or repositories before managing filter rules."

Please note that repositories are assigned to filters and it happens after defining filter rules.

Please see the steps to reproduce.

Version-Release number of selected component (if applicable):
katello-1.4.6-1.git.246.3deb1a2.el6.noarch


How reproducible:
always on above build

Steps to Reproduce:
1. Create a cv definition
2. Select repo from content tab
3. Create a filter
4. Associate repo from 'repositories' tab
5. Now click on 'Rules' tab and click 'Add New Rule' to define filter rules
6. once Rules are defined, 
7. Click on "Back to filterlist' contents and re-select the created filter in step3

Actual results:
UI throws this message even after associating repos with filters.

"This filter does not currently have any repositories assigned. Please add one or repositories before managing filter rules."

Expected results:
UI should show the created filter rules

Additional info:

Please note that this happens only when you click on "Back to filter list" and reselecting the created filter.
Comment 1 RHEL Product and Program Management 2013-09-25 05:05:49 EDT
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.
Comment 3 Brad Buckingham 2013-09-25 15:19:44 EDT
katello pull request: 

https://github.com/Katello/katello/pull/3037
Comment 6 Sachin Ghai 2013-10-21 05:56:43 EDT
Verified with snap6 compose2 (MDP2)

katello-qpid-client-key-pair-1.0-1.noarch
katello-glue-candlepin-1.4.6-40.el6sat.noarch
katello-1.4.6-40.el6sat.noarch
katello-foreman-all-1.4.6-40.el6sat.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-configure-1.4.7-6.el6sat.noarch
signo-katello-0.0.23-2.el6sat.noarch
katello-glue-elasticsearch-1.4.6-40.el6sat.noarch
ruby193-rubygem-katello-foreman-engine-0.0.12-3.el6sat.noarch
katello-cli-1.4.3-24.el6sat.noarch
katello-certs-tools-1.4.4-1.el6sat.noarch
katello-qpid-broker-key-pair-1.0-1.noarch
ruby193-rubygem-foreman-katello-engine-0.0.17-6.el6sat.noarch
katello-common-1.4.6-40.el6sat.noarch
pulp-katello-plugins-0.2-1.el6sat.noarch
katello-configure-foreman-1.4.7-6.el6sat.noarch
katello-selinux-1.4.4-4.el6sat.noarch
katello-cli-common-1.4.3-24.el6sat.noarch
katello-glue-pulp-1.4.6-40.el6sat.noarch
katello-all-1.4.6-40.el6sat.noarch
ruby193-rubygem-katello_api-0.0.3-4.el6sat.noarch


UI displays the created filter rules  when you click on "Back to filter list" and reselect the created filter. Please see the screenshot.
Comment 7 Sachin Ghai 2013-10-21 05:59:28 EDT
Created attachment 814510 [details]
rules are correctly displayed
Comment 8 Bryan Kearney 2014-04-24 13:11:08 EDT
This was verified and delivered with MDP2. Closing it out.
Comment 9 Bryan Kearney 2014-04-24 13:12:08 EDT
This was delivered and verified with MDP2. Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.