Bug 1011869 - [abrt] mate-window-manager-1.6.2-3.fc19: meta_rectangle_edge_aligns: Process /usr/bin/marco was killed by signal 6 (SIGABRT)
[abrt] mate-window-manager-1.6.2-3.fc19: meta_rectangle_edge_aligns: Process ...
Status: CLOSED DUPLICATE of bug 1226530
Product: Fedora
Classification: Fedora
Component: mate-window-manager (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Mashal
Fedora Extras Quality Assurance
abrt_hash:1bd91013ccae87b04035d22f61c...
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-25 05:53 EDT by glad08
Modified: 2016-06-20 08:19 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-20 15:42:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (21.79 KB, text/plain)
2013-09-25 05:53 EDT, glad08
no flags Details
File: cgroup (142 bytes, text/plain)
2013-09-25 05:53 EDT, glad08
no flags Details
File: core_backtrace (11.51 KB, text/plain)
2013-09-25 05:53 EDT, glad08
no flags Details
File: dso_list (8.07 KB, text/plain)
2013-09-25 05:53 EDT, glad08
no flags Details
File: environ (1.47 KB, text/plain)
2013-09-25 05:53 EDT, glad08
no flags Details
File: limits (1.29 KB, text/plain)
2013-09-25 05:53 EDT, glad08
no flags Details
File: maps (38.30 KB, text/plain)
2013-09-25 05:53 EDT, glad08
no flags Details
File: open_fds (659 bytes, text/plain)
2013-09-25 05:53 EDT, glad08
no flags Details
File: proc_pid_status (933 bytes, text/plain)
2013-09-25 05:53 EDT, glad08
no flags Details

  None (edit)
Description glad08 2013-09-25 05:53:15 EDT
Description of problem:
I close my programs and logout, then log in again and marco crashes. In general, I use compiz, bat afaik marco starts before compiz and after that compiz replaces it.

Version-Release number of selected component:
mate-window-manager-1.6.2-3.fc19

Additional info:
reporter:       libreport-2.1.7
backtrace_rating: 4
cmdline:        marco
crash_function: meta_rectangle_edge_aligns
executable:     /usr/bin/marco
kernel:         3.11.1-200.fc19.x86_64
runlevel:       N 5
type:           CCpp
uid:            1000
var_log_messages: Sep 25 13:33:13 localhost abrt[29721]: Saved core dump of pid 29090 (/usr/bin/marco) to /var/tmp/abrt/ccpp-2013-09-25-13:33:12-29090 (20348928 bytes)

Truncated backtrace:
Thread no. 1 (10 frames)
 #3 meta_rectangle_edge_aligns at core/boxes.c:1159
 #4 apply_edge_resistance at core/edge-resistance.c:391
 #5 apply_edge_resistance_to_each_side at core/edge-resistance.c:610
 #6 meta_window_edge_resistance_for_move at core/edge-resistance.c:1162
 #7 update_move at core/window.c:7010
 #8 meta_window_handle_mouse_grab_op_event at core/window.c:7450
 #9 event_callback at core/display.c:2039
 #10 filter_func at ui/ui.c:209
 #11 gdk_event_apply_filters at gdkevents-x11.c:356
 #12 gdk_event_translate at gdkevents-x11.c:946
Comment 1 glad08 2013-09-25 05:53:19 EDT
Created attachment 802671 [details]
File: backtrace
Comment 2 glad08 2013-09-25 05:53:23 EDT
Created attachment 802672 [details]
File: cgroup
Comment 3 glad08 2013-09-25 05:53:26 EDT
Created attachment 802673 [details]
File: core_backtrace
Comment 4 glad08 2013-09-25 05:53:31 EDT
Created attachment 802674 [details]
File: dso_list
Comment 5 glad08 2013-09-25 05:53:34 EDT
Created attachment 802675 [details]
File: environ
Comment 6 glad08 2013-09-25 05:53:38 EDT
Created attachment 802677 [details]
File: limits
Comment 7 glad08 2013-09-25 05:53:42 EDT
Created attachment 802678 [details]
File: maps
Comment 8 glad08 2013-09-25 05:53:45 EDT
Created attachment 802679 [details]
File: open_fds
Comment 9 glad08 2013-09-25 05:53:49 EDT
Created attachment 802680 [details]
File: proc_pid_status
Comment 10 Wolfgang Ulbrich 2013-09-28 11:02:22 EDT
You can start compiz directly with the session-manager without starting marco first.
see wiki.
http://wiki.mate-desktop.org/compiz#fedora
Comment 11 Wolfgang Ulbrich 2013-10-11 06:37:43 EDT
upstream informed.
https://github.com/mate-desktop/mate-window-manager/issues/63
Comment 12 Wolfgang Ulbrich 2014-02-15 09:47:18 EST
see https://github.com/mate-desktop/marco/issues/63#issuecomment-32473359
Upstream thinks it isn't a bug. smiley glasses
Comment 13 Wolfgang Ulbrich 2015-08-04 07:54:01 EDT
Upstream ask to test a possible fix for this issue.
Here are scratch builds for f21 and f22.
http://koji.fedoraproject.org/koji/taskinfo?taskID=10599469
http://koji.fedoraproject.org/koji/taskinfo?taskID=10599481
Please test and give feedback!
Comment 14 Wolfgang Ulbrich 2015-08-20 15:42:54 EDT

*** This bug has been marked as a duplicate of bug 1226530 ***

Note You need to log in before you can comment on or make changes to this bug.