This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1011885 - RHS-C: add node uuid in rebalance and remove-brick status output
RHS-C: add node uuid in rebalance and remove-brick status output
Status: CLOSED ERRATA
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: vdsm (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: ---
: RHGS 2.1.2
Assigned To: Bala.FA
RamaKasturi
: ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-25 06:31 EDT by anmol babu
Modified: 2015-05-13 12:26 EDT (History)
5 users (show)

See Also:
Fixed In Version: vdsm-4.12.0-177.git98c0016.el6.x86_64
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-25 02:40:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Attachment to make sure that instead of local host ,ip of the node gets displayed. (211.52 KB, image/png)
2013-11-19 04:58 EST, RamaKasturi
no flags Details

  None (edit)
Description anmol babu 2013-09-25 06:31:01 EDT
Description of problem:
Show IP of the host instead of "localhost" in rebalance status dialog: Add Gluster UUID to task status xml output (Gluster and VDSM changes)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Create a Distribute volume with at least 2 bricks
2.click on rebalance->start
3.click on rebalance->status

Actual results:
name of the host is displayed as localhost in rebalance sessions table of rebalance status pop up.

Expected results:
Ip/name of host to be displayed instead of localhost

Additional info:
Comment 2 Bala.FA 2013-10-08 03:29:01 EDT
Upstream review is at http://gerrit.ovirt.org/#/c/19597/
Comment 3 Bala.FA 2013-10-10 01:57:58 EDT
The fix is taken into the build now
Comment 4 RamaKasturi 2013-11-19 04:55:08 EST
Verified in cb8 (rhsc-2.1.2-0.24.master.el6_5.noarch). Now in the rebalance status dialog, instead of local host ip/name of the host displays.

Attaching the screen shot for the same.
Comment 5 RamaKasturi 2013-11-19 04:58:07 EST
Created attachment 825993 [details]
Attachment to make sure that instead of local host ,ip of the node gets displayed.
Comment 6 RamaKasturi 2013-11-19 05:28:52 EST
Verified in cb8 (rhsc-2.1.2-0.24.master.el6_5.noarch). Now in the rebalance status dialog instead of localhost, ip/name of the host is displayed.
Comment 8 errata-xmlrpc 2014-02-25 02:40:03 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0208.html

Note You need to log in before you can comment on or make changes to this bug.