Bug 1011897 - [origin_runtime_255]Failed to add the "first_uid" field to districts table after migration
[origin_runtime_255]Failed to add the "first_uid" field to districts table af...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Online
Classification: Red Hat
Component: Pod (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Jason DeTiberus
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-25 07:00 EDT by chunchen
Modified: 2016-09-29 22:15 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-17 09:31:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description chunchen 2013-09-25 07:00:55 EDT
Description of problem:
It is failed to add the "first_uid" field to districts table after migration.

Version-Release number of selected component (if applicable):
from devenv_stage_478 to devenv_3824

How reproducible:
always

Steps to Reproduce:
1. Setup multi-node env with devenv_stage_478 instances
2. Add nodes to broker
3. Copy ~/devenv-local and /etc/yum.repos.d/* to devenv_stage_478 instances(from devenv_3824 instance)
4. Update packages on nodes and broker 
yum -y update --enablerepo devenv-local
5. Clear the broker cache
oo-admin-broker-cache --clear --console
6. Restart rhc-broker/rhc-datastore/activemq/mcollective services
7. Run: oo-admin-clear-pending-ops --time 0
8. Run: rhc-admin-migrate-datastore --non-compatible --version 2.0.34 
9. Go to the mongo db and check the "districts" table
/> mongo openshift_broker_dev
/> db.districts.find()
10. Publish uids to nodes
oo-admin-ctl-district -c publish-uids -u <district-uuid>

Actual results:
at step 8:
Starting migration: non_compatible
Migration complete
Done!
at step 9: the "first_uid" field is not existing in the "districts" table
at step 10:
/opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/base.rb:144:in `rescue in validate_input_argument': Cannot validate input first_uid: value should be a integer (MCollective::DDLValidationError)
    from /opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/base.rb:125:in `validate_input_argument'
    from /opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:167:in `block in validate_rpc_request'
    from /opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:159:in `each'
    from /opt/rh/ruby193/root/usr/share/ruby/mcollective/ddl/agentddl.rb:159:in `validate_rpc_request'
    from /opt/rh/ruby193/root/usr/share/ruby/mcollective/rpc/client.rb:220:in `method_missing'
    from /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-msg-broker-mcollective-1.15.2/lib/openshift/mcollective_application_container_proxy.rb:2260:in `set_district_uid_limits_impl'
    from /opt/rh/ruby193/root/usr/share/gems/gems/openshift-origin-controller-1.15.2/lib/openshift/application_container_proxy.rb:78:in `set_district_uid_limits'
    from /usr/sbin/oo-admin-ctl-district:156:in `block in <main>'
    from /usr/sbin/oo-admin-ctl-district:151:in `each'
    from /usr/sbin/oo-admin-ctl-district:151:in `<main>'

Expected results:
Should add the "first_uid" field to districts table after migration successfully

Additional info:
Comment 1 Jason DeTiberus 2013-09-25 10:03:10 EDT
(In reply to chunchen from comment #0)
> 8. Run: rhc-admin-migrate-datastore --non-compatible --version 2.0.34 
> 9. Go to the mongo db and check the "districts" table
> /> mongo openshift_broker_dev
> /> db.districts.find()
> 10. Publish uids to nodes
> oo-admin-ctl-district -c publish-uids -u <district-uuid>
> 
> Actual results:
> at step 8:
> Starting migration: non_compatible
> Migration complete
> Done!
> at step 9: the "first_uid" field is not existing in the "districts" table

first_uid was not added since it is a compatible upgrade step, and rhc-admin-migrate was called with --non-compatible.

Step 8 should be Run: rhc-admin-migrate-datastore --compatible --version 2.0.34
Comment 2 chunchen 2013-09-25 22:57:53 EDT
Checked again with commands in Comment 1, it's fixed, verified from devenv_stage_478 to devenv_3829.

Note You need to log in before you can comment on or make changes to this bug.