Bug 1011913 - java-1.7.0-openjdk.x86_64 installs broken symlink
java-1.7.0-openjdk.x86_64 installs broken symlink
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: java-1.7.0-openjdk (Show other bugs)
19
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: jiri vanek
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-25 07:39 EDT by Serge Matveenko
Modified: 2013-10-01 12:39 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 12:39:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Serge Matveenko 2013-09-25 07:39:21 EDT
Description of problem:

After installing java-1.7.0-openjdk.x86_64 package there is broken symlink in /usr/lib/jvm folder.

Link /usr/lib/jvm/java-1.7.0-openjdk.x86_64 points to /usr/lib/jvm/java-1.7.0-openjdk that is not exists.


Version-Release number of selected component (if applicable):

java-1.7.0-openjdk-1.7.0.60-2.4.2.4.fc19.x86_64


How reproducible:

Install java-1.7.0-openjdk.x86_64 package 


Steps to Reproduce:

1. yum install java-1.7.0-openjdk.x86_64
2. ls $(readlink /usr/lib/jvm/java-1.7.0-openjdk.x86_64)


Actual results:

ls: cannot access /usr/lib/jvm/java-1.7.0-openjdk: No such file or directory


Expected results:

/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.60-2.4.2.4.fc19.x86_64
Comment 1 Scott Beamer 2013-09-29 23:18:46 EDT
This also applies to java-1.7.0-openjdk-devel
Comment 2 jiri vanek 2013-09-30 08:40:26 EDT
Yah. Looks wrong
Comment 3 jiri vanek 2013-10-01 09:27:49 EDT
Hm. I was not able to reproduce. After all possible install/remove/update/downgrade the links were still valid. Sorry:(
Comment 4 Serge Matveenko 2013-10-01 10:05:02 EDT
Just reproduced it on the clean F19.x86_64 installation.
Comment 5 jiri vanek 2013-10-01 10:29:27 EDT
On fresh installation the symlik may be broken. But after update?
Comment 6 Serge Matveenko 2013-10-01 11:18:17 EDT
Done "yum distro-sync"

The link "/usr/lib/jvm/java-1.7.0-openjdk.x86_64" is broken still.
Comment 7 Alexander Ivanov 2013-10-01 11:39:01 EDT
The link "/usr/lib/jvm/java-1.7.0-openjdk.x86_64" is broken still.
Comment 8 jiri vanek 2013-10-01 12:02:27 EDT
May you install also java-1.7.0-openjdk-devel ? It looks like this symlink is in wrong package - should be in devel, as /usr/lib/jvm/java-1.7.0-openjdk is controlled by devel alternatives.

I installed java-1.7.0-openjdk*, thats why I have not seen the issue. May you verify my suspicions?
Comment 9 Alexander Ivanov 2013-10-01 12:13:34 EDT
Jiri, thanks. After installing java-1.7.0-openjdk-devel symlink is NOT broken
Comment 10 jiri vanek 2013-10-01 12:39:25 EDT
Ok I' have moved the symlink to devel then. It belongs here. Sorry for troubles.

http://pkgs.fedoraproject.org/cgit/java-1.7.0-openjdk.git/commit/?h=f19&id=5a15c7112408eb930fb079eff16128d5f3f12ab6

Note You need to log in before you can comment on or make changes to this bug.