Bug 101192 - rhgb is not installed when upgrading from 'Shrike'
Summary: rhgb is not installed when upgrading from 'Shrike'
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux Beta
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: beta1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-29 22:00 UTC by Chris Hillman
Modified: 2007-04-18 16:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-30 16:15:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Chris Hillman 2003-07-29 22:00:08 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b) Gecko/20030722
Mozilla Firebird/0.6

Description of problem:
Issue: When upgrading a system running RedHat Linux 9 (Shrike), rhgb is not
installed by default.  The /etc/sysconfig/init file is modified to include
"GRAPHICAL=yes", but rhgb is not installed, and the system does not boot
graphically.

The user must manually install rhgb after the upgrade to get the graphical
bootup.  The "GRAPHICAL=yes" entry in /etc/sysconfig/init initially gave me the
impression that the necessary components were installed.

Note: Since this is one of the new features being boasted for the upcoming
release, it would be beneficial to ensure rhgb is installed so you can 'wow' the
user upon reboot.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install Shrike and configure X
2. Upgrade to Severn
3. Reboot
    

Actual Results:  The /etc/sysconfig/init file is modified to include
"GRAPHICAL=yes", but rhgb is not installed, and the system does not boot
graphically.

Expected Results:  I had expected a graphical bootup after seeing it mentioned
so often during the install.  Had to manually install rhgb after the upgrade.

Additional info:

Since this is one of the new features being boasted for the upcoming release, it
would be beneficial to ensure rhgb is installed so you can 'wow' the user upon
reboot.  Especially since they likely read about this new feature during the
install.

Comment 1 Jeremy Katz 2003-07-30 16:15:01 UTC
The upgrade process should really be more considered an "update" process -- an
upgrade does not bring in all of the new features that a fresh install would
provide (although they're then available so that you can add them after you've
updated).   We only do special cased hacks for things which will lead to a
non-functional system afterwards.


Note You need to log in before you can comment on or make changes to this bug.