Bug 1011925 - Sort Data Modeler class names in select alphabetically when adding them via 'Form data origin'
Sort Data Modeler class names in select alphabetically when adding them via '...
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Form Modeler (Show other bugs)
6.0.0
Unspecified Unspecified
medium Severity low
: ER5
: 6.0.0
Assigned To: Roger Martínez
Jan Hrcek
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-25 08:01 EDT by Jan Hrcek
Modified: 2014-08-06 16:10 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Summary: The selection list for adding Data Modeler classes as data origin in the Form Modeler is not sorted alphabetically. This makes it difficult to find and select a particular class when multiple classes are present. Cause: Data Modeler classes on the list for adding classes as data origin in the Form Modeler are not sorted alphabetically. Consequence: Difficulty in finding the desired classes on the list Fix: Please sort the list alphabetically. Result: The Data Modeler classes on the selection list are sorted in alphabetical order.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:10:03 EDT
Type: Enhancement
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Unsorted list of Data Modeler classes in select (272.41 KB, image/png)
2013-09-25 08:01 EDT, Jan Hrcek
no flags Details

  None (edit)
Description Jan Hrcek 2013-09-25 08:01:51 EDT
Created attachment 802760 [details]
Unsorted list of Data Modeler classes in select

Description of problem:
When adding Data Modeler classes as Form Data origin in Form Modeler, there is a select for choosing which class to add. Please sort the classes displayed in the select alphabeticaly. Because when multiple classes are present, it is quite hard to find the desired class in the unsorted list. See screenshot attached

Version-Release number of selected component (if applicable):
BPMS 6.0.0 ER3

How reproducible:
Always
Comment 1 Roger Martínez 2013-09-27 11:54:28 EDT
The select object values are ordered alphabeticaly.

Fixed in origin/master, see:
https://github.com/droolsjbpm/jbpm-form-modeler/commit/f64a3c29836c5c18deb69a27dc009af85ef68fbc
Comment 3 Jan Hrcek 2013-10-16 23:39:43 EDT
The problem is still present. I checked in BPMS ER4 with a decompiler and the fix is not included in it - the fix was made short time after the CR4 tag was created in the community 6.0.x branch. This is not a critical issue, so I'll leave the verification for next ER, where the fix will most likely be included.
Comment 4 Jan Hrcek 2013-12-02 03:12:36 EST
Ok, enhancement has been implemented in BPMS 6.0.0 ER5.

Note You need to log in before you can comment on or make changes to this bug.